[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] Trouble running test programs

From: Eric Blossom
Subject: Re: [Discuss-gnuradio] Trouble running test programs
Date: Mon, 20 Mar 2006 14:57:13 -0800
User-agent: Mutt/1.5.9i

On Mon, Mar 20, 2006 at 02:25:58PM -0800, jjw wrote:
> I've determined that there are two possible solutions to my problem.
> The first problem I do not have proper permissions on my user name in order
> to access the USB?  I've looked at a couple different methods for giving
> myself permissions (I have access to root) and nothing seems to work.

Which distribution are you using?

> The other issue...If I run sudo (to get around the USB permissions issues),
> it seems to ignore the environment variable for LD_LIBRARY_PATH I created
> for my user name.

yes, sudo root does ignore LD_LIBRARY_PATH.

> Does anybody know a way to give myself permissions for the USB (ideal)
> and/or to make sure the environment variables stay in place when I run sudo
> (less preferable but still good to know).

Add yourself to group usb.

Then use a hotplug script, etc change the group and permissions on
/proc/bus/usb/*/* such that group usb can r/w the file.

Try googling the archives.  This is a FAQ.  The answer depends on your


reply via email to

[Prev in Thread] Current Thread [Next in Thread]