[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] Help with building

From: Eric Blossom
Subject: Re: [Discuss-gnuradio] Help with building
Date: Mon, 12 Jun 2006 23:05:35 -0700
User-agent: Mutt/1.5.9i

On Tue, Jun 13, 2006 at 05:26:39AM +0000, Newell Jensen wrote:
> To anyone that can help,
> I am in the process of building gnuradio from CVS.  I downloaded all the 
> dependencies like sdcc, numarray, numeric, fftw3, etc. into my home folder 
> home/jensen and installed them with a script from the KD7LMO websit that is 
> linked on the gnuwiki for cvs installation.  That went good and now I am 
> trying to build gnuradio via cvs.  So I checkedout the sources into the 
> folder home/jensen/gr (which is the same gr that KD7LMO has everything 
> being built from).  Now I am trying to build the cvs stuff that was checked 
> out via the instructions on the wiki page using:
> $ sudo -v
> $  ./for-all-dirs ../buildit 2>&1 | tee make.log
> but I am getting this error:
> checking for fftw3f >= 3.0... Package fftw3f was not found in the 
> pkg-config search path. Perhaps you should add the directory containing 
> `fftw3f.pc' to the PKG_CONFIG_PATH environment variable No package 'fftw3f' 
> found
> configure: error: Library requirements (fftw3f >= 3.0) not met; consider 
> adjusting the PKG_CONFIG_PATH environment variable if your libraries are in 
> a nonstandard prefix so pkg-config can find them.
> >>>build FAILED in /home/jensen/gr/gnuradio-core

First off, life would get *so* much easier for you if you just let
everything put itself in it's default location: under /usr/local

> Please not that I fixed this error with something I found on the web that 
> said for me to do this:
> $ export PKG_CONFIG_PATH="${PKG_CONFIG_PATH}:/home/jensen/fftw-3.1.1"

To "keep it fixed" you need to export the variable in your .profile,
.bashrc, etc so that the next time you login or pop open a new window,
the variable is set.

> Yet, it only seems to work momentarily, because after a while I still get 
> the same error message.   Does anyone know how to fix it so that it stays 
> fixed?  Also, when it was working for the short time that it did, I ran 
> into another problem and that was that it said that I didn't have cppunit 
> installed but I do.  Here is the error message that I get with that:
> checking for cppunit-config... no
> checking for Cppunit - version >= 1.9.14... configure: error: GNU Radio 
> requires cppunit.  Stop
> >>>build FAILED in /home/jensen/gr/gnuradio-core
> Now I have cppunit installed and the folder is in /home/jensen/  so I don't 
> know if this is the problem?
> Since I am fairly new to everything (linux) I would appreciate any 
> pointers. Thanks.

More of the same.  Just take the default config args and install under
/usr/local.  E.g.,

  $ cd .../cppunit-<x.y.z>
  $ ./configure
  $ ./make
  $ sudo make install

  $ sudo ldconfig

You may want to consider investing in a book on Linux system
administration.  It's a good investment.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]