[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] Problem with USB on OSX?

From: Thomas Schmid
Subject: Re: [Discuss-gnuradio] Problem with USB on OSX?
Date: Mon, 31 Jul 2006 11:07:29 +0200

Hi Michael,

I installed the latest CVS version of LibUSB, but no difference. So, I
enabled the debu mode and I can see that there are a lot of:

usb_os_open(USBDeviceOpenSeize): another process has device opened for
exclusive access

But I am almost sure that there is nothing else using the USRP.

I attached the full output for test_usrp_standard_tx


On 7/30/06, Michael Dickens <address@hidden> wrote:
I can tell you from the print-out that the issue is part of LIBUSB
("usb_claim_interface") which is used by the USRP, and not the USRP's
FUSB code for Darwin.  Maybe there are patches for 0.1.12 for Intel
which are needed?  Any other Intel-mac users see this?

As a side-related note (I use a PPC desktop w/o USB 2.0 PCI card):
The benchmark_usb script sometimes works and sometimes does not
work.  When it doesn't work I generally revert back to the previous
known-working version (if possible), or try downloading and
installing everything from scratch.  While I shouldn't have to do
this, it usually fixes the issue - at least on a PPC Desktop Mac.
Maybe an Intel-Mac needs this cleansing too every so often?

On Jul 29, 2006, at 2:20 PM, Thomas Schmid wrote:

I just installed gnuradio on my macbook and I wanted to test the usrp
but got the same error as Sam:

@ enter_search
802_15_4_pkt: waiting for packet
usrp_basic_rx: failed to start end point streaming

Next I tried to use the benchmark_usb.py file and I got this error:
Testing 2MB/sec... usrp_open_interface:usb_claim_interface: failed
interface 1
usb_claim_interface: couldn't claim interface
usrp_basic_tx: can't open tx interface
Traceback (most recent call last):
  File "./benchmark_usb.py", line 106, in ?
    main ()
  File "./benchmark_usb.py", line 96, in main
    ok = run_test (rate, verbose)
  File "./benchmark_usb.py", line 63, in run_test
    usrp_tx = usrp.sink_s (0, tx_interp)
  File "/usr/local/lib/python2.4/site-packages/gnuradio/usrp.py", line
230, in __init__
    fpga_filename, firmware_filename)
  File "/usr/local/lib/python2.4/site-packages/gnuradio/usrp1.py",
line 932, in sink_s
    return _usrp1.sink_s(*args)
RuntimeError: can't open usrp1

Interestingly, the firmware is uploaded successfully, i.e., the led
first blinks fast, then slower, and then I get the error.

Any ideas on what might be wrong?

Attachment: output_withsudo
Description: Binary data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]