[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] ReG - Building GNU Radio

From: Kyle Zhou
Subject: Re: [Discuss-gnuradio] ReG - Building GNU Radio
Date: Tue, 17 Oct 2006 12:13:14 +1000

Hi, I've finally got the minimal gnuradio working.
The problem may be the outdated cygwin system.
The mirror I was using for cygwin setup is for some reason not up to date. So even though I did a 'current' installation, many of modules were outdated.
Today, I changed to another mirror site and updated my Cygwin system.
After that, both wxPython and gnuradio (min) work well without being rebuilt!
I don't figure out which module/modules cause that problem.
Probably it is python! Before the update, the python version was 2.4.1-1 ( cannot remeber exactly )
Anyway below is the current versions I am using now:
cygwin        1.5.21-2
autoconf        3.3-1
automake1.9        1.9.6-1
binutils        20060817-1
boost-devel        1.33.1-2
gcc-core        3.4.4-1
gcc-g++        3.4.4-1
libtool1.5            1.5.22-1
make                3.81-1
Numeric            24.2-1
patch                2.5.8-8
pkg-config        0.20-1
python              2.4.3-1
subversion        1.3.2-1
swig                1.3.29-2
Hope this helps
----- Original Message -----
From: Don Ward
Sent: Tuesday, October 17, 2006 2:24 AM
Subject: Re: [Discuss-gnuradio] ReG - Building GNU Radio

I'm glad you have the option of building on XP.  Please let us know how it goes, whether it works or not.
I was mistaken about wxPython needing XP/SP2.  The problem was with libusb and the USRP (http://www.comsec.com/wiki?UsrpMinGW).
----- Original Message -----
From: Kyle Zhou
Sent: Monday, October 16, 2006 10:06 AM
Subject: Re: [Discuss-gnuradio] ReG - Building GNU Radio

I am using win2kpro+sp4. maybe that's the problem.
I will try to build on winxp and see...

On 10/16/06, Don Ward <address@hidden> wrote:
What version of Windows are you running?  (I seem to recall
a website somewhere suggesting that SP2 may be needed for
the wxPython build to work correctly; I'll see if I can find
it.)  The "import gnuradio.gr" problem may be easier to work

reply via email to

[Prev in Thread] Current Thread [Next in Thread]