[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] Fedora Core 6 on PS3

From: Eric Blossom
Subject: Re: [Discuss-gnuradio] Fedora Core 6 on PS3
Date: Tue, 6 Mar 2007 08:19:16 -0800
User-agent: Mutt/1.5.9i

On Mon, Mar 05, 2007 at 11:59:39PM -0500, Tom Rondeau wrote:
> Alright, I've got my PS3 in my lab all set up with Fedora Core 6 (I
> know, Bob, you told me to go with YDL, but I needed to play around
> first). The installation went swimmingly until I tried to run a GNU
> Radio app.
> I first tried some audio components, but it was having a hard time with
> the audio card. I'm ignoring that and just want to prove I can get a
> basic flow graph running. So I tried usrp_siggen.py, which lead to a
> segmentation fault.
> A little digging showed that it occurs in basic_flow_graph.py in the
> method _check_type_match when creating the connections. It seems it
> doesn't like:
> src_size = src_sig.sizeof_stream_item (src_endpoint.port)
> Some more digging showed that the d_sizeof_stream_item vector gets the
> correct information pushed into it, but when it's read back out, it
> looks like the value is just random data in memory.
> On the other hand, I ran a test using the new hier_block2's, and it
> works just fine.
> So a few of questions:
> 1. Anyone run Fedora Core 6 successfully?
> 2. Should I try to use Fedora Core 5? (I have the ISO downloaded and
> waiting)
> 3. Is there a fix for this issue that someone can help me figure out?
> 4. Should I just stick with hier_block2 graphs and force myself to
> rewrite a number of the example codes with them?
> Thanks,
> Tom

Hi Tom,

I've currently got FC5, FC6 and YDL installed on a 320GB 7200 RPM SATA
drive.  (I'll post info on the setup on the wiki at some point.)  

I have yet to troubleshoot the Python QA failures.  Under FC5, they
segfault.  From reports from Bob, I believe the situation is the same
under YDL.  I haven't yet installed all the tool on FC6 and YDL.  The
standalone test code works fine.  I'm not sure what's wrong, and
haven't spent much time looking at the problem.

I wouldn't give up on FC6 yet, since I know the examples don't work on
FC5.  Feel free to figure out what's going on ;) 
I'll find some later this week to look at it.

I assume you built SWIG from source.  Have you tried "make check" on it?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]