[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] mblock linking error

From: Johnathan Corgan
Subject: Re: [Discuss-gnuradio] mblock linking error
Date: Mon, 12 Mar 2007 10:57:12 -0700
User-agent: Thunderbird (X11/20070306)

Daniel Garcia wrote:

> I ran in to this error today. I modified one of the iir filter files 
> and tried to rebuild the tree; it failed. I tried the 
> /etc/ld.so.conf, didn't work for me. make uninstall, then tried again
>  failed. Finally removed gnuradio by hand, checkout into new 
> directory, everything works fine now.
> From the looks of the mblock linking errors I was getting it looked
> like a previous version of the library was getting loaded instead of
> the one from the compile tree (but I'm not a build guru).

It does appear that "accidentally" linking in an already installed
library vs. one that was just compiled within the tree is still haunting
us somewhere.  A big change went into the trunk and release 3.0.3
regarding linking that appeared to fix all this, but I guess not.

Johnathan Corgan
Corgan Enterprises LLC

reply via email to

[Prev in Thread] Current Thread [Next in Thread]