[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Discuss-gnuradio] Segmentation Fault in rx_voice.py

From: Tarun Tiwari
Subject: [Discuss-gnuradio] Segmentation Fault in rx_voice.py
Date: Fri, 16 Mar 2007 00:39:44 -0500


I was trying to use rx_voice and tx_voice examples, but I found following errors on different Fedora PCs.

I have one computer (Pentium 4 Xeon 3.40GHz processor speed) with Kernel 2.6.11-1.1369_FC4smp, and another computer (Centrino Core Duo T2300 1.66GHz processor speed) with Kernel 2.6.18-1.2200.fc5smp.

When I run rx_voice.py I recieve following errors:
a) on FC4 :  Segmentation Fault
b) on FC5 :  terminate called after throwing an instance of 'std::runtime_error'
                  what():  msg length is not a multiple of d_itemsize

Then, I tried installing fftw from source code with following options:
1) ./configure --enable-sse --enable-single --enable-shared
2) ./configure --enable-single --enable-shared
3) ./configure --disable-sse --enable-single --enable-shared

but there was no improvement in the program, though all the make check worked perfect. Although GNU Radio works pretty well with the current setup, but I am not able to understand the WHY behind this problem.

Between the time, I am also not able to listen anything on receiver side. I am using RFX2400 boards with following commands:

For TX:   ./tx_voice.py --freq 2.41G -M 1 -I plughw:0,0 -v -m gmsk
For RX:  ./rx_voice.py --freq 2.41G -O plughw:0,0 -v -m gmsk

I need help on this issue.

Thanks in advance.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]