[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Discuss-gnuradio] Getting the usrp and gnuradio going... Problems

From: Bob Cameron
Subject: [Discuss-gnuradio] Getting the usrp and gnuradio going... Problems
Date: Sat, 17 Mar 2007 18:34:51 -0500
User-agent: Thunderbird (X11/20060911)

Hi all

SuSE 10.1, Subversion as of a day or two ago, sdcc built from source.
USRP box arrived here two days ago..

Configure/build of gnuradio worked fine after I grabbed all the right
packages. The SuSE instruction kind of has the wrong python path
specified but that was easy to fix. I have done the udev/hotplug mod but
am running as root whilst I work the problem.

Can turn LED on and off with usper. The USB info in /var/log/messages
looks fine.

I have plugged in a basic and 0-50MHz RX in RX A. In a fit of problem
solving I additionally plugged a basic RX into RX B.

When I try to run;

Type "cd gnuradio-examples/python/usrp" and hit Enter. Type "python
test_counting.py" and hit Enter.

The LED rate slows down and maybe 10 seconds later I get a error dump;

usrp_open_interface:usb_claim_interface: failed interface 2
could not claim interface 2: No such file or directory
usrp_basic_rx: can't open rx interface
Traceback (most recent call last):
  File "test_counting.py", line 53, in ?
    main ()
  File "test_counting.py", line 46, in main
    fg = build_graph ()
  File "test_counting.py", line 36, in build_graph
    usrp_rx = usrp.source_s (0, rx_decim, 1, 0x32103210,
  File "/usr/local/lib/python2.4/site-packages/gnuradio/usrp.py", line
266, in __init__
    fpga_filename, firmware_filename)
  File "/usr/local/lib/python2.4/site-packages/gnuradio/usrp1.py", line
1547, in source_s
    return _usrp1.source_s(*args)
RuntimeError: std::runtime_error

At this stage the LED rate is still slow. If I resubmit the command the
error dump is immediate.

As with all error messages one must look at the first one. One assumes
"Failed Interface" means it cant talk to the RX but I'd like some
thoughts on this.. Is it USB related? I saw quite a few postings on that
topic but could sort anything specific. USB related modules loaded are;

usblp                  12544  0
usb_storage            69952  1
scsi_mod              121992  3 sg,sd_mod,usb_storage
usbcore               108804  4 usblp,usb_storage,ohci_hcd
ide_core              115900  4 usb_storage,ide_cd,sis5513,ide_disk

The printer  is one of those HP All-In-One things with a front panel USB
port/flash card holder. I have yet tried to run the USRP without the
printer attached.

Maybe there needs to be a /dev entry somewhere (Thinking "No such file
or directory")

I also saw a post about checking the firmware existed in
/usr/local/share/usrp/rev4 and rev2. The filename the post had and what
I have are different! (The post was back in 2005 though)

Any thoughts or guidance appreciated

Cheers Bob W5/VK2YQA

reply via email to

[Prev in Thread] Current Thread [Next in Thread]