[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] cygwin, usb_control_msg failed: ...

From: Don Ward
Subject: Re: [Discuss-gnuradio] cygwin, usb_control_msg failed: ...
Date: Sun, 18 Mar 2007 10:37:11 -0400

"steve" wrote:

I installed libusb-win32-filter-bin- to c:\LibUSB-Win32.
I compiled the sys and dll (cd /cygdrive/c/LibUSB-Win32/src; make all).

This shouldn't be necessary; simply installing libusb from Cygwin setup should be enough.

I installed the USRP windows driver following the description at

When i look at the driver property in the device manager
i see that 'the device is working properly'. The libusb test program
detects the device as well.

When i run ./test_usrp_standard_rx.exe i get:
usb_control_msg failed: usb_control_msg: sending control message failed,
win error: A device attached to the system is not functioning.

This appears to be a new issue with version of libusb.

xfered 1.34e+08 bytes in 4.25 seconds. 3.158e+07 bytes/sec. cpu time =
noverungs = 1

I get the first error message with any tool i try to access the USRP
(usrp_rx_cfile.py for example).

usrp_oscope.py displays the same error message but i see the signal
graph (but almost no amplitude).

It sounds like everything is working despite the error message. I also get the same error message with the new libusb, but my GNU Radio applications still seem to work ok.

I will look into the problem and see what I can find out. For now you can either use it as is or go back to version of libusb.

-- Don W.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]