[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] USRP and "fusb: (rd status -71) Protocol error"

From: George Nychis
Subject: Re: [Discuss-gnuradio] USRP and "fusb: (rd status -71) Protocol error"
Date: Wed, 02 May 2007 20:08:21 -0400
User-agent: Thunderbird (X11/20070411)

Eric Blossom wrote:
On Thu, May 03, 2007 at 07:27:33AM +1000, stevie.glass wrote:

I've a rev 3 USRP which has the Flex2400 and TVRX daughtercards installed.
At one time the setup worked well - altho I've let it lie a while. This
week I've swapped out a TVRX and replaced it with the DBSRX in
preparation for a new project.

When I run usrp_fft.py things are fine for a few moments but inevitably
the program crashes with:

fusb: (rd status -71) Protocol error

repeatedly written to the terminal. Similar story for usrp_oscope.py and
most other examples.

I have in the past seen this, but mostly when I've powered down a USRP
while the application was still running.

You may want to try a different USB cable.  It might be flaky.


I'm totally not sure if this is the same error or not, but I've gotten an error -71 with the USRP before... but only when first plugging it in and then it typically would not work. Is there anything else on your USB bus? I had a webcam running on my bus also, that when I turned off and removed the error went away. I don't know if it was a synchronization or timing issue or what. Not sure if this is totally related or relevant, I just remember seeing -71

- George

reply via email to

[Prev in Thread] Current Thread [Next in Thread]