[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] Windows installation... failure to find the USRPs

From: Don Ward
Subject: Re: [Discuss-gnuradio] Windows installation... failure to find the USRPstd.ihx file...
Date: Wed, 9 May 2007 20:45:11 -0400

John Clark wrote on Wednesday, May 09, 2007 at 8:30 PM:

I've setup things on a Windows platform and wended my way through the various
required packages and build processes.

I'm at the point now where I run 'usrp_fft.py', and I receive a diagnostic
to the effect of 'can't find std.ihx'. I did a search and the file is in the following
'Msys/MinGW' environment:

where '?' is either 2 or 4.

So, the question is, what environment setting or what have you, is not
right so that the firmware file is not found correctly.

I have verified that the USRP does get loaded up if I run the diagnostic
exe files.

The problem is that GNU Radio is looking in the directory listed above, but the Windows C runtime library doesn't recognize MSYS filenames. You can fix this by doing

export USRP_PATH=C:/msys/1.0/local/share/usrp

(from your MSYS shell) before running GNU Radio.

This is a general problem with all absolute file paths that are built into the code without being set by the configure process.

-- Don Ward

reply via email to

[Prev in Thread] Current Thread [Next in Thread]