[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] VIA USB-2 combo card card, not working on linux f

From: ematlis
Subject: Re: [Discuss-gnuradio] VIA USB-2 combo card card, not working on linux for usrp
Date: Thu, 7 Jun 2007 12:29:03 -0400 (EDT)

I have an Adaptec DuoConnect AUA-1422 combo card with an NEC USB2 chipset. Using Mandriva 2007 spring on a Dell Latitude C840 with Pentium 4 m 2.6 GHz cpu I only get 16 MB/s transfer as determined by benchmark_usb.py. A little dissapointed, specially as I'm experiencing uO's with my latest 4-channel receiver app.


Eric H. Matlis, Ph.D.
Aerospace & Mechanical Engineering Dept.
120 Hessert Center for Aerospace Research
University of Notre Dame
Notre Dame, IN 46556-5684
Phone: (574) 631-6054
Fax:   (574) 631-8355

On Thu, 7 Jun 2007, Martin Dvh wrote:

Hi all,
I am using a combo pccard (USB-2 and firewire) with VIA chipset to get USB-2 on 
my laptop.

But using linux I can't get it to work.
I get usrp overruns, (uOuOuO) even with decimation factors of 200 when using 
This is only 320 ksamples/sec

with top I see that the CPU is 80 % idle, so that is not the problem.

When running benchmark_usb.py I get slightly better performance, 2 MB/sec works 
and 4 MB/sec works sometimes, all above fail.

I don't know why benchmark_usb works better then usrp_rx_cfile.

When I run usrp_wfm_rcv_nogui.py I get garbled sound and uO and aU, but this is 
logical. The script doesn't get enough data from the USRP.

On windows usrp_rx_cfile.py just works fine with the same usb-2 card. (This is 
a much older gnuradio/usrp release though)

Does anybody have a clue, what is wrong here.

I tried both kernel 2.6.18 and 2.6.20. I also tried noacpi acpi=off apm=off as 
kernel-boot param.

Or does anybody have a suggestion of an USB-2 addon card for a notebook 
(pccard) that works with the USRP.


Discuss-gnuradio mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]