[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] Error in my first USRP test

From: Alaelddin Mohammed
Subject: Re: [Discuss-gnuradio] Error in my first USRP test
Date: Thu, 21 Jun 2007 10:19:44 +0200
User-agent: Thunderbird (Windows/20070604)

it works now, thank you
But, when I tried to run usrp_spectrum_sense.py I got this

$ python usrp_spectrum_sense.py
Traceback (most recent call last):
 File "usrp_spectrum_sense.py", line 9, in ?
   from usrpm import usrp_dbid
ImportError: No module named usrpm

what is wrong now please.

Don Ward wrote:

----- Original Message ----- From: "Alaelddin Mohammed" <address@hidden>
To: <address@hidden>
Sent: Wednesday, June 20, 2007 11:17 AM
Subject: Re: [Discuss-gnuradio] Error in my first USRP test

I found that I am using libusb-win32 version, I change it to version I plugged TX and RX in my USRP device. but I got this error.

$ python test_counting.py
found 5 busses
found 5 busses
usrp_open_interface:usb_claim_interface: failed interface 2
could not claim interface 2, interface invalid
usrp_basic_rx: can't open rx interface
Traceback (most recent call last):
 File "test_counting.py", line 53, in ?
   main ()
 File "test_counting.py", line 46, in main
   fg = build_graph ()
 File "test_counting.py", line 36, in build_graph
usrp_rx = usrp.source_s (0, rx_decim, 1, 0x32103210, usrp.FPGA_MODE_COUNTING) File "/usr/local/lib/python2.4/site-packages/gnuradio/usrp.py", line 266, in __init__
   fpga_filename, firmware_filename)
File "/usr/local/lib/python2.4/site-packages/gnuradio/usrp1.py", line 1502, in source_s
   return _usrp1.source_s(*args)
RuntimeError: can't open usrp1

This is normal for Windows libusb0 the first time you try to access the USRP. If you try it again (without removing power to the USRP) it should work. See http://www.gnuradio.org/trac/wiki/WindowsTips for more tips on using GNU Radio with Windows.

-- Don W.

What shall I do now please

Discuss-gnuradio mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]