[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] 802.11 BBN in SuSE

From: Greg Troxel
Subject: Re: [Discuss-gnuradio] 802.11 BBN in SuSE
Date: Mon, 02 Jul 2007 09:28:10 -0400
User-agent: Gnus/5.110007 (No Gnus v0.7) Emacs/21.4 (berkeley-unix)

Teun <address@hidden> writes:

> has anyone tried to capture live 802.11b - 1mbit packets using the 802.11BBN
> source code in SuSE ?

I am pretty sure we did this under some kind of Linux, and I think it
was SuSE.

> I'm trying to do so, but I'm encountering problems. First of all, when I run
> usrp_fft or usrp_oscope I can definitely see something. At least, I see
> power fluctuations due to my laptop's WLAN (old 802.11b) card. However, if I
> try to run ./bbn_80211b_tx.py I get the following error:
> "
> Using TX d'board A: Flex 2400 Tx MIMO B
>>>> gr_fir_ccf: using SSE
> spb:    8
> interp: 32
> Failed to set Tx frequency to 2.4G "

We didn't have any MIMO cards, so you may be simply hitting a minor bug.

> I also tried to capture packets, using ./bbn_80211b_rx.py -d 8 -f 2412e6 -p
> , however I can't see any packets.

The barker code demod defaults to off (probably not a wise choice).
Make sure it's on - I suggest reading the code and the option parsing in
particular.    This is all a bit rough.

I definitely received 802.11 packets (1 Mb/s) under NetBSD.   So while
I'm sure there are things wrong, it's possible to make it work.

See the tap example; that's what I ran most recently.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]