[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] Problem with udp-sink/source over a network

From: Dev Ramudit
Subject: Re: [Discuss-gnuradio] Problem with udp-sink/source over a network
Date: Fri, 06 Jul 2007 09:26:25 -0400
User-agent: Icedove (X11/20070329)

Johnathan Corgan wrote:
Dev Ramudit wrote:

socket connect: Invalid argument
terminate called after throwing an instance of 'std::runtime_error'
 what():  can't connect to socket

You must have the remote listener already running before running the
sender script.

I've got the remote listener running (I've tested this over the course of 4-5 hours, with every configuration I can think of). Nmapping the computers shows that the port is being opened when I run the listener, running the source application locally also works fine, but remotely I always receive the above error. I've tried all combinations of "localhost" and the public IP that I can think of, with no luck. I'm going to try to write out everything in C++ and figure out why the error to the connect() call is being thrown. If anyone has any other suggestions, please let me know.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]