[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] Problem with udp-sink/source over a network

From: Dev Ramudit
Subject: Re: [Discuss-gnuradio] Problem with udp-sink/source over a network
Date: Fri, 06 Jul 2007 10:50:46 -0400
User-agent: Icedove (X11/20070329)

Tom Rondeau wrote:
Dev Ramudit wrote:
Johnathan Corgan wrote:
Dev Ramudit wrote:

socket connect: Invalid argument
terminate called after throwing an instance of 'std::runtime_error'
 what():  can't connect to socket
You must have the remote listener already running before running the
sender script.

I've got the remote listener running (I've tested this over the course
of 4-5 hours, with every configuration I can think of). Nmapping the
computers shows that the port is being opened when I run the listener,
running the source application locally also works fine, but remotely I
always receive the above error. I've tried all combinations of
"localhost" and the public IP that I can think of, with no luck. I'm
going to try to write out everything in C++ and figure out why the
error to the connect() call is being thrown. If anyone has any other
suggestions, please let me know.

What port are you trying to use? Have you tried to run your scripts
between machines on the same network (that is, same subnet; not through
a router or anything)?


Discuss-gnuradio mailing list
I've generally tested with the 65500 port that the scripts have, but I've also changed this to 13421 (and a couple of others) with the same problem. I've tested on machines in the same network and subnet, which are all able to see each other and connect to other ports through other applications. Has anyone else tried running the vector_source.py and vector_sink.py scripts remotely? Just want to clarify if this is an issue with my setup.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]