[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] Losing data somewhere between USRP and hard drive

From: Eric Blossom
Subject: Re: [Discuss-gnuradio] Losing data somewhere between USRP and hard drive
Date: Sun, 12 Aug 2007 23:31:57 -0700
User-agent: Mutt/1.5.9i

On Sun, Aug 12, 2007 at 06:10:21PM -0700, Chris Stankevitz wrote:
> Hello,
> Q1: If I use a file_sink to record data, and my app never reports "Ou" 
> on the console, have all the bits been written to disk?
> Q2: Does anyone have a suggestion about how I can avoid Ou messages when 
> using file_sink?

  * If using ext3 file system, try remounting it as ext2.
  * Buy a faster disk.  

> Q1 commentary: Sometimes the data I get from file_sink looks funky.  It 
> could be a problem with my implementation of my application, but I 
> suspect the data is corrupted and I suspect it contains gaps eventhough 
> no "Ou" was reported.

No clue.  usrp_rx_cfile.py is known to work ;)

> Q2 commentary: Ramdisk doesn't work because I'm writing gigabytes of 
> data.  I am thinking maybe I could write a multithreaded file_sink that 
> operates more cleverly than the currently implementation.  I am sampling 
> 4e6 complex short samples per second.

What OS are you using?
What filesystem are you using?

Have you tried benchmarking your filesystem i/o throughput?
How about testing for any "pauses" where nothing else can get done.
E.g., posting the ext3 journal.

> I have also tried sending the data over TCPIP using
> file_descriptor_sink attached to a python socket with
> setblocking(0).  Even when the receiving server is just throwing
> away the data (i.e. no disk access or processing) data is sometimes
> lost.

16MB/s * 8 bits/byte = 128Mbit/s
Are you using gigabit ethernet?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]