[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] Problem with 8-bit option and dropped samples

From: Lisa Creer
Subject: Re: [Discuss-gnuradio] Problem with 8-bit option and dropped samples
Date: Tue, 21 Aug 2007 21:16:22 -0400

On 8/20/07, Eric Blossom <address@hidden> wrote:
On Mon, Aug 20, 2007 at 11:15:36PM -0400, Lisa Creer wrote:
> I'm testing the -8 option in various example programs, and haven't been
> successful in receiving valid data.  The following test resulted in a very
> brief, flat line being displayed, then absolutely no data showed on the
> graph, but the program continued to run.
>  ./usrp_fft.py -f 100M -d 4 -8
> format = 0x288
> set_format = True

Have you tried increasing the gain?

Yes, to no avail.

What daughterboard are you using?

Basic Rx.

Do you have an antenna connected?  If so, what kind?

Yes.  My antenna ignorance will become apparent here, it's what I'd call a basic antenna (non-telescoping), vertical antenna 14 inches tall  with a strong magnet on the bottom.

> I decided to try decimating by 4 without specifying the 8-bit option, and I
> received the 'uO' indicating that samples were dropped from the USRP to
> host, but data was displayed on the graph, and it was 16MHz wide.  What's
> going on?
> ./usrp_fft.py -f 92.7M -d 4
> uOuOuOuOuOuOuOuOuOu

64 MS/s / 4 * 4 bytes/S = 64MB/s.  This won't fit across the USB,
hence the continuous overruns.

Wait, I thought the -8 option provided 8-bit  I and 8-bit Q across the USB. It sounds like you're saying the samples are still 4 bytes total (2 byte each I and Q). So the samples are converted to shorts AFTER they get to the host? Then how can we decimate by 4 when using the -8 option? How can we cram more data through the USB if it can only handle 32 MB/s?

Have you tried using the existing usrp_rx_cfile.py program?  It's
known to work.

Yes. Nothing but zeroes in data file. However, when a gain of 30 db is applied some data appears in the file. But when a gain of 30 db is used in usrp_fft.py, there is no change. Hrmph.

$ ./usrp_rx_cfile.py -d 4 -8 -s out -f 92.7e6
Using RX d'board A: Basic Rx
USB sample rate 16M
address@hidden usrp]$ hexdump out
0000000 0000 0000 0000 0000 0000 0000 0000 0000

> Any idea what is happening here? I'm wondering if my signal is so weak, that
> the 8-bit option is truncating all the data off.

Could be.  It currently takes the high 8 bits of the 16-bit value.

[I thought that somebody had implemented the barrel shifter, but
checking rx_buffer.v, I don't see it.]

> When running usrp_wfm_rcv.py I can only get one strong FM radio station.

Seems unlikely, unless you're living in the middle of nowhere...

No. My traditional FM radio sitting next to the USRP (with a bigger antenna) gets many FM stations.

Have you tried:

$ usrp_fft.py -f 95M -d 8

Should show lots of stations...

I wouldn't say lots...(see usrp_fft_95M_d8.png)

What OS and distribution are you running on?

Red Hat Enterprise Linux 4.3 


Attachment: usrp_fft_95M_d8.png
Description: PNG image

reply via email to

[Prev in Thread] Current Thread [Next in Thread]