[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Discuss-gnuradio] Re: benchmark_ofdm_rx not working

From: Archana Ragothaman
Subject: [Discuss-gnuradio] Re: benchmark_ofdm_rx not working
Date: Mon, 22 Oct 2007 16:35:08 -0400

On 10/22/07, address@hidden < address@hidden> wrote:
Send Discuss-gnuradio mailing list submissions to


Message: 6
Date: Mon, 22 Oct 2007 10:43:50 +0100
From: Tom Rondeau < address@hidden>
Subject: Re: [Discuss-gnuradio] benchmark_ofdm_rx not working
To: GNU Radio Discuss <address@hidden>
Message-ID: < address@hidden>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed

Archana Ragothaman wrote:
> Hello,
> I am using two USRPs rev 4 and two RFX2400. I am basically trying to
> make the USRPs communicate with each other using the
> benchmark_ofdm_tx.py and benchmark_ofdm_rx.py scripts. The commands I
> am executing are
> ./benchmark_ofdm_tx.py -f2.4e9 -T A (at one USRP connected to laptop)
> ./benchmark_ofdm_rx.py -f2.4e9 -R A (at the other USRP connected to
> another laptop)
> The benchmark_ofdm_tx.py script is working as I can see the packet
> number displayed(I wrote a print pktno in the script)
> However the benchmark_ofdm_rx.py script does not give any output. I
> don't think the rx_callback function is being executed(as the packets
> are printed in that function).
> Can anyone please help me out and give suggestions as to what the
> problem could be?
> Thank you.

First, try running the benchmark_ofdm_tx on one side and tht usrp_fft to
display the received power at the receiver. What does this look like?

The problem is likely that you are not transmitting enough power. There
is a --tx-amplitude flag to adjust this. Set it to 2000 - 4000.



I increased the amplitude to around 3000 on the tx usrp. I also ran the usrp_fft.py on the rx side. I could observe the spectrum of the rx signal which was around 30 dB. So I know that the rx side usrp is able to receive the packets trasnmitted. However, now when I run the benchmark_ofdm_rx.py script on the rx side, I do not see any output. The output that I get is

After rx_callback( ) definition
>>> gr_fir_ccf: using SSE
>>> gr_fir_fff: using SSE
INIT Completed Successfully!!!!
fg=usrp_graph(....) called (comment added for debugging)
gr_buffer::allocate_buffer: warning: tried to allocate
   20 items of size 1600. Due to alignment requirements
   64 were allocated.  If this isn't OK, consider padding
   your structure to a power-of-two bytes.
   On this platform, our allocation granularity is 4096 bytes.
fg.start() (comment added for debugging)
Inside RX _Callback pktno (comment added for debugging)
ok: False        pktno: 58626    n_rcvd: 1       n_right: 0

  Only one packet is received after a long time.  Could you suggest as to why the output is not displayed?

Archana Ragothaman
Master's in Telecommunications
Graduate Research Assistant
University of Maryland, College Park
Email: address@hidden
Phone: 240-422-7887
reply via email to

[Prev in Thread] Current Thread [Next in Thread]