[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re:[Discuss-gnuradio] undefined symbol error:

From: Qi Chen
Subject: Re:[Discuss-gnuradio] undefined symbol error:
Date: Mon, 3 Mar 2008 09:57:09 -0600


On Mar 3, 2008, at 8:33 AM, Michael Dickens wrote:

On Mar 2, 2008, at 9:28 PM, Qi Chen wrote:
ImportError: /usr/local/lib/python2.4/site-packages/gnuradio/gr/ _gnuradio_swig_py_runtime.so: undefined symbol: _ZN28gr_single_threaded_scheduler4stopEv

It looks like '/usr/local/lib' isn't in the library search path. If you're running on some versions of Linux, you'll need to update the ld.so cache after installing GNU Radio:

$ cat /etc/ld.so.conf
--> if /usr/local/lib isn't in this file, then do the following 3 commands; otherwise, go to the end and run that command:
I ran the above command and /usr/local/lib wasn't included

$ cp /etc/ld.so.conf /tmp/ld.so.conf
$ echo /usr/local/lib >> /tmp/ld.so.conf
$ sudo mv /tmp/ld.so.conf /etc/ld.so.conf

after executing those three line, the path was successfully included.

$ sudo ldconfig

I tried running the same script, it's giving me the same error message

now try running those GNU Radio scripts again and if it still fails, please include your computer's setup info: how you installed GNU Radio, OS and version, how you installed background apps and such. - MLD

My machine is running fedora 6, and all source files are stored on a network drive. I built everything from there. I checked with out sys admin about the permission, looks ok. It wasn't a fresh install, it was upgraded from the older version, after I checked out the latest version from /trunk, I did the following:

sudo make && make check ( I had to use sudo here for some permission reason)
sudo make install

everything looked fine after those steps, no error messages (after I got the permission issue fixed).

I didn't reinstall all the dependencies, coz they were already installed, and the I could run the previous gnuradio software and scripts no problem.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]