[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] GPS on USRP

From: Eric Blossom
Subject: Re: [Discuss-gnuradio] GPS on USRP
Date: Wed, 5 Mar 2008 12:50:19 -0800
User-agent: Mutt/1.5.17 (2007-11-01)

On Wed, Mar 05, 2008 at 03:15:16PM -0500, Paul Creekmore wrote:
> It would be helpful to know exactly what you mean by "this isn't 
> happening."  What /does/ happen?  Anything?  Do you get a data file?  Have 
> you tried recording and plotting a simple test sinewave?
> You could also very easily convert the data in MATLAB.
> --Paul
> Phaysal Khan wrote:
>> Hi,
>> I used usrp_fft, and I can see a CW at 1575.42MHz, so it means that it is 
>> in the working condition, although I still get the same error msg once 
>> everytime i run anything. It says
>> $python usrp_fft.py -f 1.57542G
>> usb_contro_msg failed: usb_control_msg: sending control message failed, 
>> win error: A device attached to the system is not functioning.
>>  But as I said, that I can see the generated CW on the usrp_fft graph, and 
>> the CW displayed on this graph follows the changes in frequency and 
>> amplitude made from signal generator, then I think we can ignore this 
>> error msg. We should be ready to move forward.
>>  I am trying to use usrp_rx_cfile.py which I have altered as:
>>     u = usrp.source_c (0, options.decim, 1, gru.hexint(options.mux), 0)
>>     u.set_rx_freq (0, options.ddc_freq)
>>     u.set_pga (0, options.gain)
>>     u.set_pga (1, options.gain)
>>     c2r=gr.complex_to_real()
>>     dst = gr.file_sink (gr.sizeof_float, options.output_file)
>>     #fg.connect (u, dst)
>>     fg.connect(u,c2r,dst)
>> also, I am saving data to file as:


If you are using only u.set_rx_freq, your modifications have removed
the ability to set the LO on the daughterboard.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]