[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Discuss-gnuradio] Big bugs out of nowhere...

From: Jared Jensen
Subject: [Discuss-gnuradio] Big bugs out of nowhere...
Date: Fri, 14 Mar 2008 10:48:29 -0400

I haven't been using my usrp for a little while.  I've been porting my code to a TI C64x+.  I came back to my usrp today and tried to run just a basic receive for test data for my TI DSP.  I got the following error.  In usbview I see a "USRP Rev4" under my ehci controller.  I thought it might be the board, so I grabbed my other usrp, and the exact same thing happened.  (This is with gnuradio-3.1.1 )  So I tried my older gnuradio install, and tried to run usrp_fft.py... and the same things happened.  I checked /usr/local/share/usrp.  It has all of the rbf (see below).  Has anyone encountered this before?  It was just a few months back everything was great... I didn't touch gr for a while... came back and BOOM.  :(  No joy.

usb_control_msg failed: error sending control message: Protocol error
usb_control_msg failed: error sending control message: Protocol error
usb_control_msg failed: error sending control message: Protocol error
usrp: failed to load fpga bitstream /usr/local/share/usrp/rev4/std_2rxhb_2tx.rbf.

Traceback (most recent call last):
  File "./usrp_wfm_rcv.py", line 289, in <module>
    app = stdgui2.stdapp (wfm_rx_block, "USRP WFM RX")
  File "/usr/local/lib/python2.5/site-packages/gnuradio/wxgui/stdgui2.py", line 36, in __init__
    wx.App.__init__ (self, redirect=False)
  File "/usr/lib/python2.5/site-packages/wx-2.6-gtk2-unicode/wx/_core.py", line 7700, in __init__
  File "/usr/lib/python2.5/site-packages/wx-2.6-gtk2-unicode/wx/_core.py", line 7352, in _BootstrapApp
    return _core_.PyApp__BootstrapApp(*args, **kwargs)
  File "/usr/local/lib/python2.5/site-packages/gnuradio/wxgui/stdgui2.py", line 39, in OnInit
    frame = stdframe (self.top_block_maker, self.title, self._nstatus)
  File "/usr/local/lib/python2.5/site-packages/gnuradio/wxgui/stdgui2.py", line 60, in __init__
    self.panel = stdpanel (self, self, top_block_maker)
  File "/usr/local/lib/python2.5/site-packages/gnuradio/wxgui/stdgui2.py", line 81, in __init__
    self.top_block = top_block_maker (frame, self, vbox, sys.argv)
  File "./usrp_wfm_rcv.py", line 79, in __init__
    self.u = usrp.source_c()                    # usrp is data source
  File "/usr/local/lib/python2.5/site-packages/gnuradio/usrp.py", line 248, in __init__
    fpga_filename, firmware_filename)
  File "/usr/local/lib/python2.5/site-packages/gnuradio/usrp1.py", line 1232, in source_c
    return _usrp1.source_c(*args)
RuntimeError: can't open usrp1

<prompt>:/proc$ cd /usr/local/share/usrp/rev4/
total 840k
drwxr-xr-x 2 root root 4.1k 2007-11-12 11:57 ./
drwxr-xr-x 4 root root 4.1k 2007-08-20 20:45 ../
-rw-r--r-- 1 root root 181k 2007-11-12 11:56 multi_2rxhb_2tx.rbf
-rw-r--r-- 1 root root 181k 2007-11-12 11:56 std_2rxhb_2tx.rbf
-rw-r--r-- 1 root root 182k 2007-11-12 11:56 std_4rx_0tx.rbf
-rw-r--r-- 1 root root  18k 2007-11-12 11:56 std.ihx
-rw-r--r-- 1 root root 123k 2007-11-12 11:57 usrp_radar_mono.rbf
-rw-r--r-- 1 root root 114k 2007-11-12 11:57 usrp_sounder.rbf


Need to know the score, the latest news, or you need your HotmailĀ®-get your "fix". Check it out.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]