[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Discuss-gnuradio] Mac OS X Build problem

From: Qi Chen
Subject: [Discuss-gnuradio] Mac OS X Build problem
Date: Wed, 19 Mar 2008 01:15:51 -0500

Hi all,

I have been trying to install the latest stable release (v3.1) on Intel-Mac with Mac OS X(10.4.11). I have tried to follow both Jon Jacky and Michael Dickens's build guide, I had different problems.
Anyways, the problems can be concluded as follows:
1. Since GNURadio 3.1 requires numpy instead of old Numeric, hence I either have to use python 2.4 installed by macports or I have to make numpy work on python2.4 (I failed to do so, not sure why). 2. I tried to use python 2.4 (import numpy no problem), this is the command I used to build:

        setenv GR /opt/local
./configure --prefix=$GR --with-pythondir=$GR/lib/python2.4/site- packages
        sudo make insall


3. When I tried to use mac build-in python (2.3.5), with numpy installed the error message I got while running some python script:

        Traceback (most recent call last):
          File "sounder_tx.py", line 23, in ?
            from gnuradio import gr, usrp, eng_notation
File "/usr/local/lib/python2.3/site-packages/gnuradio/usrp.py", line 27, in ?
            from gnuradio import gru
File "/usr/local/lib/python2.3/site-packages/gnuradio/gru/ __init__.py", line 37, in ?
            exec "from gnuradio.gruimpl.%s import *" % (f,)
          File "<string>", line 1, in ?
File "/usr/local/lib/python2.3/site-packages/gnuradio/gruimpl/ freqz.py", line 57, in ?
            import numpy
File "/System/Library/Frameworks/Python.framework/Versions/2.3/lib/ python2.3/site-packages/numpy/__init__.py", line 50, in ?
            import ma
File "/System/Library/Frameworks/Python.framework/Versions/2.3/lib/ python2.3/site-packages/numpy/ma/__init__.py", line 14, in ?
            import core
File "/System/Library/Frameworks/Python.framework/Versions/2.3/lib/ python2.3/site-packages/numpy/ma/core.py", line 113, in ? max_filler.update([(k,-numpy.inf) for k in [numpy.float32, numpy.float64]])
        AttributeError: keys

I doubt this is the problem of numpy. I did notice that numpy requires python2.4 or higher, I am not sure if there is a work around or not. Any hint would be appreciated.

Am I missing something somewhere?

Thanks in advance.

Qi Chen

reply via email to

[Prev in Thread] Current Thread [Next in Thread]