[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] GNU Radio on VMWare

From: Michael Dickens
Subject: Re: [Discuss-gnuradio] GNU Radio on VMWare
Date: Sat, 22 Mar 2008 11:39:30 -0400

Up front: Did you try installing via the instructions at < http://www.gnuradio.org/trac/wiki/FedoraInstall >, or via some other method? The first few lines are somewhat critical to making sure the correct dependencies are available.

On Mar 21, 2008, at 8:36 PM, Mr. mollasadra wrote:
I'm trying to install gnu radio on a fedora8 installation inside VMWare. First, I wanted to know if that is even possible to do for development (inside virtual machine development)?

Yes, this is possible. I've just created one ... haven't tried it with a USRP, but the software runs scripts that don't require the USRP hardware.

Second, I tried installing gnu radio and when i tried to do

I get this:

The following components were skipped either because you asked not
to build them or they didn't pass configuration checks:


These components will not be built.

Which I'm not sure if should be getting in the first place.
Is this okay?
Yes, you might get this response. You could get the USRP and some others to compile, by installing the correct dependencies. I would guess that 'sdcc' isn't in PATH correctly. See the FedoraInstall wiki page.
if yes then how come when I make and install, and the run one of the demos I get this:

address@hidden audio]$ python dial_tone.py
Traceback (most recent call last):
  File "dial_tone.py", line 23, in <module>
    from gnuradio import gr
ImportError: No module named gnuradio
address@hidden audio]$

could this be related?
If no, then what does that first error means?

I would guess 2 primary possibilities (could be both):

1) "/usr/local/lib" is not in the ldconfig search path (e.g. like the issue with Debian / Ubuntu). You can correct this via the instructions found in the section "Broken libtool on Debian and Ubuntu" at the bottom of < http://www.gnuradio.org/trac/wiki/UbuntuInstall >.

2) "/usr/local/lib/python2.5/site-packages" is not in your shell environment's PYTHONPATH. This is addressed in the FedoraInstall wiki page found at this top of this email.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]