[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] MinGW install problem

From: Walker, Robert CIV NSWC Crane, WCE Aviation Systems Staff
Subject: Re: [Discuss-gnuradio] MinGW install problem
Date: Tue, 15 Apr 2008 14:55:12 -0400

Don - I ran through all of these updates (autoconf 2.59, automake 1.9.5,
libtool 1.5.22) using the mingwPORT as you suggested.  However, I
couldn't get your "sed" command to work properly so just edited
"aclocal" and "autoconf" manually to replace "C:" with "/C/".  After
doing all of this, I did have to delete my gnuradio-3.1.2 directory and
start over from "tar -zxf gnuradio-3.1.2.tar.gz", but from there on I
just followed the current instructions.  Everything seems to have built
properly and things seem to be working.

Two other things:

1) I recalled mention of NumPy as a requirement vice Numeric so
installed it a while back, but notice your instructions still reference
Numeric.  Is NumPy not required?

2) I happened to notice the required SDL version changed from 1.2.11 to
1.2.13 so it might be worth highlighting that fact in the instructions.

Thanks a lot for your help!



Message: 6
Date: Sat, 12 Apr 2008 19:21:47 -0400
From: "Don Ward" <address@hidden>
Subject: Re: [Discuss-gnuradio] MinGW install problem
To: "Walker, Robert  CIV NSWC Crane,    WCE Aviation Systems Staff"
        <address@hidden>,       <address@hidden>
Cc: address@hidden
Message-ID: <address@hidden>
Content-Type: text/plain; format=flowed; charset="UTF-8";

Don Ward wrote:


GNU Radio 3.1.2 requires several MSYS/MinGW packages that were not
required by earlier releases.  You need the following:

 - autoconf 2.59 (or later)
 - automake 1.9.5 (or later)
 - libtool 1.5 (or later)


I also needed an extra step to work around a problem in automake:

aclocal_exe=`which aclocal`
sed s,C:/,/C/,g $aclocal_exe > aclocal.tmp mv -f aclocal.tmp

You may need to repeat the above step, substituting "autoconf" for

You may need to start a new MSYS shell for the new versions of the above
tools to be seen.

These added requirements are also required for building from the svn
repository.  They are needed because the Windows versions of libtool do
not know how to track interlibrary dependencies.

Let me know if these instructions work or if they need corrections.
When we get a set that works, I will add them to the wiki.

-- Don W.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]