[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Discuss-gnuradio] ps3 gnuradio

From: Charles Swiger
Subject: [Discuss-gnuradio] ps3 gnuradio
Date: Sat, 31 May 2008 13:45:52 -0400

Here's what I found on the ps3 system so far:

Current system software is 2.35 and had to use a later
'CELL-Linux-CL-20080201-ADDON.iso' otherwise got a blank screen on
'start other os'. 20071023 is the version in the wiki, I'll try to
update things at some time.

Kernel 2.6.21 works fine but has the shutdown hang issue. Kernel 2.6.24
reboots ok but is missing nfsd.ko, or I just could not otherwise get nfs
to work. Turning off all unnecessary services and modules got 160 out of
217MB free ;)

Plow through cross compile, build failed with -j6, but worked with just
'make'. Wiki says -j2.

'make check' fails with a segfault in 'gcell/src/apps/test_all'.
Commenting out 'runner.addTest(qa_gcell_wrapper::suite());' makes it
work again.

Played around with some of the other apps and got this nice chart:

Went ahead and did 'make install', set PYTHONPATH and imported gr and
audio. Tried dialtone but got 'audio_alsa_sink[hw:0,0]: failed to set
access mask: Invalid argument'. Used a file sink and got
'gr_vmcircbuf_createfilemapping: createfilemapping is not available' but
got a bunch of output that plots correctly on a big-endian machine.

Finally found that 'audio.sink(48000,"plughw:0,0")' works.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]