[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Discuss-gnuradio] Re: AttributeError: 'BoxSizer' object has no attribut

From: Jonathan Friedman
Subject: [Discuss-gnuradio] Re: AttributeError: 'BoxSizer' object has no attribute 'AddStretchSpacer' running usrp_fft.py
Date: Fri, 20 Jun 2008 02:16:53 -0700

SOLVED. There is an error with the FAQ at

The recommended packages install for Hardy (and several other versions) is:

sudo apt-get -y install g++ automake1.9 libtool python-dev fftw3-dev
libcppunit-dev libboost-dev sdcc libusb-dev libasound2-dev
libsdl1.2-dev python-wxgtk2.6 subversion guile-1.6 libqt3-mt-dev

Which as you can see incorrectly refers to "python-wxgtk2.6". The
correct package is "python-wxgtk2.8". The error messages occur because
some functionality required by usrp gui's was not yet implemented in
version 2.6... such as the addStrechSpace() method of the Sizer class.


On Fri, Jun 20, 2008 at 1:52 AM, Jonathan Friedman <address@hidden> wrote:
> Hello all. I am new to gnuradio. I installed gnuradio on a three computers 
> (a) an Ubuntu 6.06 P4-mobile laptop, (b) an Ubuntu 8.04 Dell SX270 mini 
> desktop, and (c) an Ubuntu 8.04 Dell Precision 560 dual Xeon-2.4GHz. On each 
> machine I compile from source following the install directions for Ubuntu on 
> the FAQ. On (a) everything runs perfectly, on (b) the command-line based 
> stuff works, but the GUI always fails out with some error like the one shown 
> below before starting, on (c) same as (b). I am working with the usrp 
> hardware and have tried it with two different motherboards (both version 4.1) 
> -- both work correctly on (a) and give the same error messages on both (b) 
> and (c). I've copied an example trace below. I get different errors for 
> different gui's. QWT-5.0.2 was installed from source per the FAQ. I modified 
> /etc/lib.so.conf to include /usr/local/lib per the FAQ as well.
> Thanks! -Jonathan
> address@hidden:~/gnuradio/gr-utils/src/python# ./usrp_fft.py
> Traceback (most recent call last):
>   File "./usrp_fft.py", line 306, in <module>
>     main ()
>   File "./usrp_fft.py", line 302, in main
>     app = stdgui2.stdapp(app_top_block, "USRP FFT", nstatus=1)
>   File "/usr/local/lib/python2.5/site-packages/gnuradio/wxgui/stdgui2.py", 
> line 36, in __init__
>     wx.App.__init__ (self, redirect=False)
>   File "/usr/lib/python2.5/site-packages/wx-2.6-gtk2-unicode/wx/_core.py", 
> line 7700, in __init__
>     self._BootstrapApp()
>   File "/usr/lib/python2.5/site-packages/wx-2.6-gtk2-unicode/wx/_core.py", 
> line 7352, in _BootstrapApp
>     return _core_.PyApp__BootstrapApp(*args, **kwargs)
>   File "/usr/local/lib/python2.5/site-packages/gnuradio/wxgui/stdgui2.py", 
> line 39, in OnInit
>     frame = stdframe (self.top_block_maker, self.title, self._nstatus)
>   File "/usr/local/lib/python2.5/site-packages/gnuradio/wxgui/stdgui2.py", 
> line 60, in __init__
>     self.panel = stdpanel (self, self, top_block_maker)
>   File "/usr/local/lib/python2.5/site-packages/gnuradio/wxgui/stdgui2.py", 
> line 81, in __init__
>     self.top_block = top_block_maker (frame, self, vbox, sys.argv)
>   File "./usrp_fft.py", line 124, in __init__
>     avg_alpha=options.avg_alpha)
>   File "/usr/local/lib/python2.5/site-packages/gnuradio/wxgui/fftsink2.py", 
> line 175, in __init__
>     self.win = fft_window(self, parent, size=size)
>   File "/usr/local/lib/python2.5/site-packages/gnuradio/wxgui/fftsink2.py", 
> line 308, in __init__
>     self.control_panel = control_panel(self)
>   File "/usr/local/lib/python2.5/site-packages/gnuradio/wxgui/fftsink2.py", 
> line 241, in __init__
>     control_box.AddStretchSpacer()
> AttributeError: 'BoxSizer' object has no attribute 'AddStretchSpacer'

reply via email to

[Prev in Thread] Current Thread [Next in Thread]