discuss-gnuradio
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Discuss-gnuradio] RE: Using two USRPs in one computer


From: JUAN LARA AMBEL
Subject: [Discuss-gnuradio] RE: Using two USRPs in one computer
Date: Mon, 25 Aug 2008 18:26:39 +0200

Hi all again,

at the end, it's enough by following the "src1 = usrp.source_c(which=0)" 
approach as prescribed. It seems to be working: one USRP acting as Tx in one USB
plug and the other USRP acting as Rx into another USB plug: just modifying less 
than 20 lines of code -always on top of the usrp.source_c / usrp.sink_c. Fine!

regards,

________________________________________
De: address@hidden address@hidden En nombre de JUAN LARA AMBEL address@hidden
Enviado el: jueves, 21 de agosto de 2008 19:51
Para: address@hidden
Asunto: [Discuss-gnuradio] Using two USRPs in one computer

Hi all,

I've got two USRP from Ettus Research. After having mounted both individually 
with success, i'm trying to connect both of them to my PC via two
different USB plugs; just to run comfortably some experiments prior setting up 
a larger testbed.

I've browsed the mailing list archives back to a post on Thu, 9 Aug 2007 
11:31:54, where is suggested to let the 'usrp.source_c' Python function know
which usrp we're addressing, i.e. invoking something like:

src1 = usrp.source_c(which=0)
src2 = usrp.source_c(which=1)

I've modified slightly some Python Receiver examples (from the BBN guys 
repository, but for the matter of my question i'think it makes no difference) 
so that now
I can specify this 'which' variable to either 0/1 from the command line and 
feed the "usrp.source_c" from GnuRad properly.

The result is that if I run the Receiver in say USRP '1', so that its FPGA gets 
loaded (which can be checked through the frequency of the blinking small green 
LEDs on
the USRP motherboard) and afterwards run again the Receiver into USRP '1' then 
I got a crash and the second USRP FPGA is not loaded. So far, totally normal.

However, when I run the receiver example in say, URSP 0, whose FPGA gets loaded 
without problems, and afterwards run the receiver example in USRP 1, there
is a collision. Indeed, the later USRP doesn't seem to get loaded correctly its 
FPGA because the right (D402) green LED doesn't blink at any time when it 
should do it once;
but the left one (D403) changes to a lower blinking frequency as normally.

Further in this situation I got something like this in the Ubuntu Cmd for USRP 
0 (totally normal log but the last two lines):

You selected (default) USRP #0
Bits Per Encoded Sample = 8
adc frequency =  64000000
decimation frequency =  16
input_rate =  4000000
gain =  45.0
desired freq =  2400000000.0
baseband frequency 2396000000.0
dxc frequency -4000000.0
Samples per data bit =  8
>>> gr_fir_ccf: using SSE
_reap: usb->status = -71, actual_length =  2560
fusb: (rd status -71) Protocol error

And got this for USRP 1:

usrp_open_interface:usb_claim_interface: failed interface 2
could not claim interface 2: Device or resource busy
usrp_basic_rx: can't open rx interface
Traceback (most recent call last):
  File "bbn_80211b_rx_USRP_SELECT.py", line 198, in <module>
    main ()
  File "bbn_80211b_rx_USRP_SELECT.py", line 193, in main
    app = app_flow_graph()
  File "bbn_80211b_rx_USRP_SELECT.py", line 177, in __init__
    options.freq, options.which_usrp)
  File "bbn_80211b_rx_USRP_SELECT.py", line 76, in __init__
    self.u = usrp.source_c(which_usrp, decim_rate=decim)
  File "/usr/local/lib/python2.5/site-packages/gnuradio/usrp.py", line 249, in 
__init__
    fpga_filename, firmware_filename)
  File "/usr/local/lib/python2.5/site-packages/gnuradio/usrp1.py", line 1232, 
in source_c
    return _usrp1.source_c(*args)
RuntimeError: can't open usrp1

So I figure that there some point below "usrp.source_c" where the "pipes" 
towards each USB/USRP may collide.
┬┐or is it maybe some another missconfiguration from my side?

May anybody give me a clue on this?

Thanks in advance,

Juan


_______________________________________________
Discuss-gnuradio mailing list
address@hidden
http://lists.gnu.org/mailman/listinfo/discuss-gnuradio




reply via email to

[Prev in Thread] Current Thread [Next in Thread]