[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] Problem with inband USRP

From: Marc Petit-Huguenin
Subject: Re: [Discuss-gnuradio] Problem with inband USRP
Date: Wed, 07 Jan 2009 09:15:59 -0800
User-agent: Mozilla-Thunderbird (X11/20090103)

Marc Petit-Huguenin wrote:
> Hi,
> When running test_usrp_inband_rx, it gets stuck because it does not
> receive any data.  Is there a problem with the code in the trunk?
> (revision #10191).  The USRP is working fine with the legacy code
> (e.g. usrp_rx_cfile).  Here's the output of the program (with the
> verbose flag set in usrp_server):
> [USRP_SERVER] Initializing...
> [TEST_USRP_INBAND_RX] Requesting RX channel allocation
> [USRP_SERVER] Checking chan: 0 owner () size 2
> [USRP_SERVER] Assigning channel: 0 to rx0
> [TEST_USRP_INBAND_RX] Receiving...
> [USRP_SERVER] Sending read request down to start recv
> Kernel: 2.6.26 for amd64 (tested also with i386)
> libusb-0.1: 0.1.12
> libc6: 2.7
> libstdc++6: 4.3.2

The problem seems to be in usrp_rx.cc, line 123:

  d_urx =
    boost::any_cast<usrp_standard_rx *>(pmt_any_ref(pmt_nth(1, data)));

This code throws the following exception:

exception: boost::bad_any_cast: failed conversion using boost::any_cast

I tried with boost 1.35 and 1.37, with the same result.

Can somebody help?


Marc Petit-Huguenin
Home: address@hidden
Work: address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]