[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] Newbie need help with installing gnuradio 3.1.3

From: Josh Blum
Subject: Re: [Discuss-gnuradio] Newbie need help with installing gnuradio 3.1.3
Date: Sun, 15 Feb 2009 01:55:14 -0800
User-agent: Thunderbird (X11/20090105)

Pete Kay wrote:

Thank you for all your help.  I got gnuradio installed now.   To test it
with my USRP boards, I am having a few questions:

1. I followed the example and tried to run the  ./usrp_oscope.py, but the
file is not under:

address@hidden usrp]# ls /usr/local/share/gnuradio/examples/usrp
fm_tx_2_daughterboards.py  usrp_nbfm_ptt.py        usrp_wfm_rcv_nogui.py
fm_tx4.py                  usrp_nbfm_rcv.py        usrp_wfm_rcv_pll.py
max_power.py               usrp_spectrum_sense.py  usrp_wfm_rcv.py
test_dft_analysis.py       usrp_test_loop_lfsr.py  usrp_wfm_rcv_sca.py
test_dft_synth.py          usrp_tv_rcv_nogui.py    usrp_wxapt_rcv.py
usrp_am_mw_rcv.py          usrp_tv_rcv.py
usrp_benchmark_usb.py      usrp_wfm_rcv2_nogui.py

read the part about setting PYTHONPATH http://gnuradio.org/trac/wiki/FedoraInstall

2. When I tried to run ./usrp_wfm_rcv.py, I am getting:

address@hidden usrp]# ./usrp_wfm_rcv.py 101.5
Traceback (most recent call last):
  File "./usrp_wfm_rcv.py", line 23, in <module>
    from gnuradio import gr, gru, eng_notation, optfir
ImportError: No module named gnuradio

How to fix these problems?

3.  I have 2 RFX900 and a USRP, when positioning my RFX900 boards on USRP
motherboard, the two RFX900 boards should be oriented in opposition
direction and as long as the four holds of the RFX900 boards matched with
the USRP motherboard's, I am putting it correctly right?  I just want to
confirm it before I charge up the board.

Yes, RX side A is next to the TX on side B and vice-versa: http://img129.imageshack.us/img129/9764/usrp_v4.jpg

The holes on the daughter boards must line up with the holes on the main board. Make sure!! Put in the screws if you must.

4. In chapter 4 of the gnuradio tutorial, it mentioned that I can test my
USRP configuration by " Then connect your speaker to the sound card and
insert a piece of wire to the RX-A connector" ,  How to insert " a piece of
wire" to the RX-A connector.  What kind of wire do I need and what should I
connect the wire to on the other end?

Perhaps if you have a basic RX daughter board, you could stick a wire into the SMA connector and get some FM or AM audio signals. Any type of wire will do, just strip it and stick it into the center hole on the connector.

Same for the TVRX daughter board.

5. Is there any other ways of testing my USRP configuration?

Sorry for asking so many questions.  I hope to be able to get started
quickly and be able to contribute back to the community as much as I can.

You can do a loop back test. Connect the RX to the TX, generate a signal with usrp_siggen.py and receive the signal with usrp_fft.py.

Make sure you check usrp_fft.py --help and usrp_siggen.py --help and get all the options right.

Thanks in advance for all your help.


If you are feeling adventurous, install the latest gnuradio development trunk or the 3.2 release candidate branch and check out GRC: http://gnuradio.org/trac/wiki/GNURadioCompanion


On Sun, Feb 15, 2009 at 3:24 AM, Josh Blum <address@hidden> wrote:

Pete Kay wrote:


I am just getting started with gnuradio on Fedora 9.

While running ./bootstrap, I am getting the following error:

address@hidden gnuradio-3.1.3]# ./bootstrap
gr-trellis/doc/Makefile.am:51: `%'-style pattern rules are a GNU make

It could just be a warning, can you run ./configure after ./bootstrap?

Double check http://gnuradio.org/trac/wiki/FedoraInstall


 I have automake installed on my system already.  Does anyone know why and
how to fix this problem?

Thanks in advance for your help.



Discuss-gnuradio mailing list


Discuss-gnuradio mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]