[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] USRP2 and external clock (from GPS receiver)

From: Matt Ettus
Subject: Re: [Discuss-gnuradio] USRP2 and external clock (from GPS receiver)
Date: Fri, 20 Feb 2009 10:04:26 -0800
User-agent: Thunderbird (X11/20090105)

Douglas Geiger wrote:
 Ok - now that I've discovered I had some bad cabling - specifically a
bad T-splitter: the side going to my O-scope worked, the side going to
my USRP2's did *not* - which I suppose can be chalked up to user error.
I am now able to synchronize the clocks - both with the firmware/fpga
code you sent, and the version I had built locally.


 However - once I start running my code on the host PC, the clock loses
sync. I have to power down, and re-power-up the USRP2 for the clock to
lock onto my external source again. This is with the firmware/fpga from
svn r10441, and my host code. I've tried calling ->config_mimo and
- ->sync_to_pps() as soon as I create my USRP2 objects, but that didn't
seem to help.

Sync_to_pps is all about timestamps and the pps input, so it is not related to whether or not the clock is locked.

Just to clarify the clocking architecture on the USRP2, there are basically 3 modes:

 - Free running
 - Locked to the external SMA reference input
 - Locked to the clock which comes over the MIMO cable from another USRP2

You need to make sure you are in the 2nd one, aka "we lock to SMA". It sounds like whatever code you are running is setting the mode to "we lock to MIMO connector" mode.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]