[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] GNU Radio 3.2 Release Candidate 2 available for

From: Johnathan Corgan
Subject: Re: [Discuss-gnuradio] GNU Radio 3.2 Release Candidate 2 available for testing
Date: Mon, 20 Apr 2009 08:08:57 -0700

> I checked out the trunk and tried compiling the code. I get the
> following error message in in the middle of the compile. I have tried
> compiling the latest trunk and also R10877 and still get the same
> error. I did the regular ./bootstrap and used
> ./configure --enable-doxygen --with-boost=/opt/boost_1_36
> --enable-usrp2=no --enable-gr-usrp2=no

BTW, you likely don't need to disable the usrp2 components in the
above, though that isn't the source of your problem.

> g++ -g -O2 -g -O2 -pthread -pthread -Wall -Woverloaded-virtual -o
> .libs/test_inband test_inband.o  ./.libs/libusrp-inband-qa.so
> /home/anankekarthik/gnuradio/usrp/host/lib/inband/.libs/libusrp-inband.so.0:
> undefined reference to `usrp_standard_rx::tune(int,
> boost::shared_ptr<db_base>, double, usrp_tune_result*)'

This looks like the build system is getting confused as to the
location of libusrp (which contains the functions above).  Just to
start from a known configuration, can you do a 'sudo make uninstall'
to ensure the system locations are devoid of any GNU Radio
libraries/header files, the start from scratch with the bootstrap


reply via email to

[Prev in Thread] Current Thread [Next in Thread]