[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] usb connection USRP

From: Eric Blossom
Subject: Re: [Discuss-gnuradio] usb connection USRP
Date: Fri, 24 Apr 2009 16:42:08 -0700
User-agent: Mutt/1.5.18 (2008-05-17)

On Fri, Apr 24, 2009 at 03:33:40PM -0600, Don Latham wrote:
> OK. Finally managed to get the gnuradio compiled and installed. Now I've
> put the recommended 10-usrp.rules file in the right place, checking the
> syntax twice, and tried all the suggested steps (reboot, start/stop udev,
> killall etc.). When I look at /dev/bus/usb, I see the "owners" of the
> device as root root instead of root usrp. lsusb shows the device is there,
> lsusb -v shows std.ihx has not loaded.
> Further, running the datarate example <./usrp_benchmark_usb.py>, brings
> the joyous news:
> "could not claim interface operation not permitted" and the subsequent
> failure to load std.ihx. I have made the usrp group and am happy to be a
> member of same. The failure seems to be that the device belongs to root
> root and not to root usrp? I tried to fix that, but of course failed
> miserably, and none of the books I have here give me a clue as to the
> arcane structure of usb interface software structure. I should mention
> that unplugging and replugging the usb cable or restarting the usrp helps
> at all. Oh woe. Can you help?
> Thanks again!
> Don


I know you said you checked the syntax, but just to be sure, you've
got GROUP:="usrp", MODE:="0666" right?  Without the ":=" part, it's possible
that the rule gets overridden by a later rule.

You might check /var/log/messages (or where ever udevd logs) for
additional hints.  See $ man 7 udev


reply via email to

[Prev in Thread] Current Thread [Next in Thread]