[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Discuss-gnuradio] gnuradio 3.2 install error

From: Alex young
Subject: [Discuss-gnuradio] gnuradio 3.2 install error
Date: Mon, 07 Sep 2009 07:42:46 -0400


I hope someome can help me understand what I am doing wrong. I am
attempting to install release 3.2 and have run into errors. I am running
Ubuntu 8.04 on x86. The version of gnuradio is revision 11635.

The error seems to involve boost, but I followed the boost instructions
and ./configure completed properly as far as I can tell. Here are the
boost sections from the ./configure output:

checking for boost >= 1.35... yes
checking whether the boost::thread includes are available... yes
checking for exit in -lboost_thread-gcc42-mt-1_37... yes
checking whether the boost::date_time includes are available... yes
checking for exit in -lboost_date_time-gcc42-mt-1_37... yes
checking whether the boost::program_options includes are available...
checking for exit in -lboost_program_options-gcc42-mt-1_37... yes

However, when I run make, this is what I get: 

creating libgnuradio-core-qa.la
(cd .libs && rm -f libgnuradio-core-qa.la && ln
-s ../libgnuradio-core-qa.la libgnuradio-core-qa.la)
if g++ -DHAVE_CONFIG_H -I. -I. -I../../..  -DOMNITHREAD_POSIX=1
-I/work/gnuradio/gnuradio_3.2/gruel/src/include    -g -O2  -Wall
-Woverloaded-virtual -pthread -MT gnuradio.o -MD -MP -MF
".deps/gnuradio.Tpo" -c -o gnuradio.o gnuradio.cc; \
        then mv -f ".deps/gnuradio.Tpo" ".deps/gnuradio.Po"; else rm -f
".deps/gnuradio.Tpo"; exit 1; fi
/bin/bash ../../../libtool --tag=CXX --mode=link g++ -g -O2  -Wall
-Woverloaded-virtual -pthread   -o gnuradio  gnuradio.o
libgnuradio-core.la -lboost_program_options-gcc42-mt-1_37
g++ -g -O2 -Wall -Woverloaded-virtual -pthread -o .libs/gnuradio
gnuradio.o  ./.libs/libgnuradio-core.so
/usr/bin/ld: cannot find -lboost_program_options-gcc42-mt-1_37
collect2: ld returned 1 exit status
make[5]: *** [gnuradio] Error 1
make[5]: Leaving directory
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/work/gnuradio/gnuradio_3.2/gnuradio-core'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/work/gnuradio/gnuradio_3.2'
make: *** [all] Error 2

I did ldconfig and tried it again from the beginning, and I always get
the same thing. And for thoroughness, I checked the contents
of /etc/ld.so.conf, and it is shown below:

address@hidden:~$ cat /etc/ld.so.conf
include /etc/ld.so.conf.d/*.conf



I know I have installed 3.2 successfully before, and I tried several
attempts this time, but I can't figure out what I am doing differently,
(and wrong.)

Does anyone have any ideas about what I am doing wrong?

Thanks very much,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]