[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] start_rx_streaming_at patch

From: Douglas Geiger
Subject: Re: [Discuss-gnuradio] start_rx_streaming_at patch
Date: Thu, 17 Sep 2009 14:15:50 -0400

 In the firmware directory the important files are the app_common_v2.c
and .h file, and txrx.c (serdes_txrx.c and a bunch of the others I
think are mainly for testing). It looks like the host code (i.e. the
patches to libusrp2) all applied successfully, which is good. I have
been using that code, so if you are able to manually apply the patch
(i.e. go in and figure out where the changes need to happen - there's
a couple added functions, and some changes made in the control loop of
app_common and txrx). My patch added code to serdes_txrx,
mimo_tx_slave, and factorytest only because I added a function
declaration in app_common_v2, and so I needed a NOP definition in
those .c files for the build to be successful.
 In this end this patch was just a hack to get the functionality I
needed until the switchover to the VRT code on the USRP2 - so yes, it
works (i.e. it will wait to start streaming rx samples back until the
fpga clock/counter reaches the specified number), but it's not meant
to be the long-term solution.

On Thu, Sep 17, 2009 at 1:30 PM, Bruce McGuffin <address@hidden> wrote:
> Doug
> I tried a bunch of different p levels. At -p0 it finds the files right away,
> but
> still fails to update them.
> Redoing patch with -p0 I get:
>     address@hidden gnuradio-3.2]$ patch -p0 <
> usrp2-rx_at-sync_rx_at.patch
>    patching file usrp2/firmware/apps/serdes_txrx.c
>    Hunk #1 FAILED at 183.
>    1 out of 1 hunk FAILED -- saving rejects to file
> usrp2/firmware/apps/serdes_txrx.c.rej
>    patching file usrp2/firmware/apps/app_common_v2.c
>    Hunk #1 FAILED at 477.
>    1 out of 1 hunk FAILED -- saving rejects to file
> usrp2/firmware/apps/app_common_v2.c.rej
>    patching file usrp2/firmware/apps/app_common_v2.h
>    Hunk #1 FAILED at 55.
>    1 out of 1 hunk FAILED -- saving rejects to file
> usrp2/firmware/apps/app_common_v2.h.rej
>    patching file usrp2/firmware/apps/txrx.c
>    Hunk #1 FAILED at 158.
>    Hunk #2 FAILED at 211.
>    2 out of 2 hunks FAILED -- saving rejects to file
> usrp2/firmware/apps/txrx.c.rej
>    patching file usrp2/firmware/apps/factory_test.c
>    patching file usrp2/firmware/apps/mimo_tx_slave.c
>    Hunk #1 FAILED at 191.
>    1 out of 1 hunk FAILED -- saving rejects to file
> usrp2/firmware/apps/mimo_tx_slave.c.rej
>    patching file usrp2/host/include/usrp2/usrp2.h
>    Hunk #1 succeeded at 172 (offset -5 lines).
>    patching file usrp2/host/lib/usrp2_impl.cc
>    patching file usrp2/host/lib/usrp2_impl.h
>    patching file usrp2/host/lib/usrp2.cc
>    patching file usrp2/host/lib/control.h
> So I guess it worked on more than just the last file, as I originally said,
> but still
> didn't manage to update what look like essential files. e.g. serdes_txrx.
> Are these patches still useful? That is, if I went through the files by hand
> and made
> the changes, would I wind up with usable code?
> Thanks
> Bruce

Doug Geiger

reply via email to

[Prev in Thread] Current Thread [Next in Thread]