[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Discuss-gnuradio] re: USB writing problem

From: Alexander Chemeris
Subject: [Discuss-gnuradio] re: USB writing problem
Date: Tue, 22 Sep 2009 13:56:39 +0400

Hi All,

Sorry for starting new thread, I've just subscribed to the list and can't
repy to old thread.

I also see a lot of aforementioned errors when I try to run OpenBTS.
And I see them regularly, not occasionally. I use Ubuntu 9.04 x64
on IBM/Lenovo ThinkPad T60. It uses ICH7 for USB. I can provide
'lspci -v' later if needed.

I experienced these errors when I ran OpenBTS's transceiver with
non-realtime priority. When I run it with realtime priority (Round
Robin with 80 priority) I do not recall to see them. Even then I still see
regular "TRX-> USRP Underrun" messages, but that's for another topic,
I think. So my guess is that this is somehow related to scheduling
and may be caused by bursts of writes to USB.

PS I use OpenBTS 1.6 which use its own fpga code.

Alexander Chemeris.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]