[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Discuss-gnuradio] Did you ever come across this type of error?

From: Mir M. Ali
Subject: [Discuss-gnuradio] Did you ever come across this type of error?
Date: Wed, 2 Dec 2009 16:13:02 -0600

Dear Dr. Daigle,
If you remember I told you that I rewrote the transmission side of my system such that there is no usrp involved. But this system doesn't work and it shows an error that I can't resolve. The error is as shown below,
gr_fir_fff: using SSE
gr_vmcircbuf_sysv_shm: shmget (0): No space left on device
gr_buffer::allocate_buffer: failed to allocate buffer of size 64 KB
terminate called after throwing an instance of 'std::bad_alloc'
  what():  std::bad_alloc

Apparently, this is due to failure in allocation of enough memory. When I commented out the lines in the original transmit_path.py that involves usrp and replaced the usrp_sink with a file_sink I get the same error. Any ideas?

I first tried to use your model of qa_test to write a transmitter but I am wasn't sure about the way to pass multiple packets to the message_queue. I may need some help on this.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]