[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] Error installing wxPython on CYGWIN in Windows XP

From: Shabbir Ahmed
Subject: Re: [Discuss-gnuradio] Error installing wxPython on CYGWIN in Windows XP
Date: Fri, 15 Jan 2010 16:58:16 +1100

Thank you Don. I dont think I am capable of solving the problems faced. Too advanced for me. Meanwhile, I tried MSYS-MINGW and it didnt work either. Will post the errors on another mail.


On Thu, Jan 14, 2010 at 12:47 AM, Don Ward <address@hidden> wrote:
Shabbir Ahmed wrote:

A. Managed to install and work wxWidgets but I just cannot manage wxPython.
Anyhow the following is how I managed wxWidgets and errors found in trying
to install wxPython.

B. Referring to http://gnuradio.org/redmine/wiki/gnuradio/WxPythonCygwin

STEP 4: ( I had to add a few more lines that I took from wxPython's src
http://www.wxpython.org/BUILD.html .. so now we have)

CC="gcc -mno-cygwin -mwindows"  \
CXX="g++ -mno-cygwin -mwindows" \
LDFLAGS="-mno-cygwin -mwindows" \

The -mno-cygwin option says to create a native Windows version rather than a Cygwin version, which gets around the winsock.h vs. select.h problem.  But it is not clear whether a non-Cygwin extension will work with the Cygwin version of Python.

../configure \
   --with-msw \
   --build=i686-pc-mingw32 \
   --prefix=/usr/local \

STEP 4a, 5 and 6: Remains the same.

STEP 7: (there is slight change the cygwx*.dll files are now wx*.dll files..
so we have)

mv /usr/local/lib/wx*.dll /usr/local/bin

STEP 8: so now when you try step 8 it WORKS!

STEP 9: (But now I am stuck in STEP 9 and cannot move forward tried all
possibilities the following is the code I am using and the output+errors...)

python setup.py build_ext --inplace WXPORT=msw COMPILER=mingw32
WX_CONFIG="bash.exe -e


WARNING: WXWIN not set in environment. Assuming '..'
Preparing CORE...
Preparing STC...
Preparing GIZMOS...
running build_ext
building '_core_' extension
gcc -mno-cygwin -mdll -O -Wall -DSWIG_TYPE_TABLE=_wxPython_table
-D__WXMSW__ -Iinclude -Isrc -I/usr/local/lib/wx/include/msw-ansi-release-2.8
-I/usr/local/include/wx-2.8 -I/usr/include/python2.5 -c src/helpers.cpp -o
build/temp.cygwin-1.7.1-i686-2.5/src/helpers.o -mthreads -O3

In file included from /usr/include/python2.5/Python.h:57,
                from src/helpers.cpp:15:
/usr/include/python2.5/pyport.h:257:24: sys/select.h: No such file or

Your Cygwin version of Python wants to use select.h, which doesn't exist in you non-Cygwin (i.e., -mno-cygwin) environment.  Again, I don't know if it is possible to build non-Cygwin extensions for a Cygwin Python.

The good news is that this problem has been reported on the wxWidgets bug tracker and is being worked on (see http://trac.wxwidgets.org/ticket/11626). The bad news, is that the supposed "correct" answer is to modify the code (if possible) to use posix networking calls in place of the Windows calls.

-- Don W.

Shabbir Ahmed
PhD. Student
Centre for Telecommunications and Microelectronics
Victoria University
Email: address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]