[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] Unable to tune Tx or Rx with XCVR2450 on USRP2

From: Manav Seth
Subject: Re: [Discuss-gnuradio] Unable to tune Tx or Rx with XCVR2450 on USRP2
Date: Thu, 28 Jan 2010 19:12:08 -0700

Ya..i know...but if i put a legal value..its saying cannot receive on channel 0..its strainge..but dont know what is happening...
can somebody please help...
its happening with all the example programs...I have also now modified quite a few example scripts which are for usrp older version to work with usrp2..but for them also..its giving the same errors...though they use to work with the older usrp...

On Thu, Jan 28, 2010 at 7:04 PM, Matt Ettus <address@hidden> wrote:

The -f argument to usrp2_fft.py is the frequency.  By putting "-f 1000" you are telling the system to try to tune the xcvr2450 to 1 kHz.  The specified range is 2.4-2.5 GHz and 4.9 to 5.9 GHz.  1 kHz is WAY outside of that range.  I would suggest you try something like:

usrp2_fft.py -f 5.7G


On 01/28/2010 05:35 PM, Manav Seth wrote:
Actually no...its always returning false...
when I use usrp2_fft.py with -f 1000 then output does come but still it
is unable to set the initial frequency though it did receive.

I am still trying to figure out the problem...

On Thu, Jan 28, 2010 at 3:43 PM, Ian Holland
<address@hidden <mailto:address@hidden>> wrote:

   On Wed, Jan 27, 2010 at 8:52 PM, Ian Holland
   <address@hidden <mailto:address@hidden>>

   Hi All

   I have been trying to set the Tx and Rx frequencies when using an
   XCVR2450 with a USRP2, but it seems these keep failing. A snippet of my
   source code is below for setting the Tx frequency.
   The output of this portion of code is "Failed to tune Tx", and the
   frequencies are all 0, with spectrum_inverted being false.
   I have also tried to use usrp2_fft.py, and this fails saying nothing is
   received on channel 0.
   Does anyone know what the problem could be?



   /* try tuning Tx to a test frequency */
               double Fc = 2400000000.0;
               usrp2::tune_result TxTuneResult;
               bool successTx = device->set_tx_center_freq(Fc,
               if(successTx) {
                                    cout << "Tx Tune Successful:\n";
                    cout << "    Baseband Frequency: " <<
   TxTuneResult.baseband_freq << "\n";
                    cout << "    DxC Frequency: " <<
   TxTuneResult.dxc_freq << "\n";
                    cout << "    Residual Frequency: " <<
   TxTuneResult.residual_freq << "\n";
                    cout << "    Spectrum Inverted: " <<
   (TxTuneResult.spectrum_inverted ? "true" : "false") << "\n";
               else {
                                    cout << "Failed to tune Tx.\n";
                    cout << "    Baseband Frequency: " <<
   TxTuneResult.baseband_freq << "\n";
                    cout << "    DxC Frequency: " <<
   TxTuneResult.dxc_freq << "\n";
                    cout << "    Residual Frequency: " <<
   TxTuneResult.residual_freq << "\n";
                    cout << "    Spectrum Inverted: " <<
   (TxTuneResult.spectrum_inverted ? "true" : "false") << "\n";
               cout << "\n";


    >From: Manav Seth [mailto:address@hidden
    >Sent: Thursday, 28 January 2010 3:29 PM
    >To: Ian Holland
    >Cc: address@hidden <mailto:address@hidden>

    >Subject: Re: [Discuss-gnuradio] Unable to tune Tx or Rx with XCVR2450
   on >USRP2

    >Ya, its failing for me too...set_tx_center_freq is always failing
   (though I >am writing my code in python)..
    >not able to find the cause...

   Have you been able to get any of the pre-written scripts (e.g.
   usrp2_fft.py or usrp_siggen.py) working? I can't even get those to work.
   I tried usrp_siggen.py in verbose this morning and noticed again it was
   unable to set the Tx frequency. Also, I think the error I had mentioned
   above re usrp2_fft.py would be because the rx frequency couldn't be set.

   I have tried two of the daughtercards on one USRP2, and one of those two
   cards on the other USRP2, and still can't get it to set, though it
   worked fine using the same code for the BasicTx and BasicRx.

Discuss-gnuradio mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]