[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] u2_flash_tool : Can not find the command

From: Johnathan Corgan
Subject: Re: [Discuss-gnuradio] u2_flash_tool : Can not find the command
Date: Wed, 3 Mar 2010 10:18:53 -0800

On Wed, Mar 3, 2010 at 08:14, Andy_Long <address@hidden> wrote:

> I have run this command successful. But the usrp2 is still not working
> properly. The problem is that only one LED light (F) is on after inserting
> the 2Gb SD card (normal SD card produced by sandisk).

This usually means the firmware was not loaded correctly, as Eric mentioned.

> Another strange thing is that after inserting the SD card into the USRP2, it
> can not recognized by Ubuntu 9.04 anymore. Thus every time I have to format
> it in windows before I am using u2_flash_tool to rewrite the firmware and
> FPGA again. (I have tried to format it as FAT,FAT32,NFTS which makes no
> difference. Because I guess the u2_flash_tool will remove the file system
> created by windows).

The SD card does not use a filesystem; there is no need to format it.
In fact, when you write it with u2_flash_tool, you are overwriting any
pre-existing filesystem metadata like partition tables, etc.  That is
why Ubuntu doesn't "recognize" it afterwards.

When you insert the SD card into a reader,  the OS will see a new
block device come online, like /dev/sdb or /dev/sdf or some other
device name depending on what other block devices you have in the
machine.  A properly programmed SD card (for the USRP2) will not have
a recognized partition table, so your kernel will not try to mount it
into the VFS.

Also, after programming the card, you must insert it into the USRP2
and power cycle the USRP2 before trying 'find_usrps'.

> I am wandering if I did anything wrong when I am using the u2_flash_tool to
> burn the firmware? Or maybe I have to try to use another brand SD card
> rather than Sandisk? Or Do I need to do something more with SD card before
> using u2_flash_tool?

It's possible you need to use another brand card, as these seem to be
notoriously flaky.  But your u2_flash_tool commands appeared correct.
One thing to try would be to remove the SD card from the reader after
the write command, then insert it back in before the verify command.
This will ensure you are not simply verifying the firmare/FPGA images
against the disk cache.

I know you seem to be having a lot of difficulty, but I can assure you
that I've programmed SD cards for the USRP2 dozens or hundreds of
times with stock and custom images, and what exists does work fine if
properly done.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]