[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Discuss-gnuradio] VRT-branch bug?

From: Per Zetterberg
Subject: [Discuss-gnuradio] VRT-branch bug?
Date: Fri, 26 Mar 2010 13:50:52 +0100
User-agent: Internet Messaging Program (IMP) H3 (4.0.5)

Dear UHD developers and all,

I hope you don't stop reading this because it's about the obsolete VRT-branch. It may apply to UHD as well.

Everything I have tried with the VRT-branch has worked until today. This is nice because I have been looking for the "transmit at time t" functionality for many years.

I can perfectly synchronize the transmitter and receiver by setting: "hdr.integer_secs=10; hdr.fractional_secs=0" in transmitter and "t.secs=10; t.ticks=0" in the receiver. If I change to t.ticks=400, in the receiver the received signal is shifted as it is supposed to. However, if I set "hdr.fractional_secs=100" or anything else nothing happens. It seems as if the ".fractional_secs" field is ignored.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]