[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Discuss-gnuradio] Receiving ATSC using USRP2

From: Jared Casper
Subject: [Discuss-gnuradio] Receiving ATSC using USRP2
Date: Sat, 27 Mar 2010 13:36:12 -0700

Hi all,

I've got a USRP2 with a WBX attempting to receive ATSC signals.  I'm
using the latest (git HEAD on 27 March 2010) version of everything
(firmware and software).  usrp2_fft.py shows a strong signal for a
local tv transmitter (680 - 686 MHz).

It looks like the ATSC code is written for the original USRP, using a
decimation of 10 to get 6.4 Msps, interpolated by three to get 19.2
Msps.  Since I have a USRP2, I can't get exactly 6.4 Msps.  Has anyone
gotten this to work using a USRP2?

I've tried using 5, 10, and 20 Msps, interpolating up to 20 Msps (I've
also tried various gains).  In addition to changing the interpolation
rate in interp_short.py, I've gone through the code and changed 19.2e6
to 20e6 in interp_short.py, fpll.py, xlate.py, atsc_fpll.cc, and
atsc_bit_timing_loop.cc.  However, nothing is output from ./btl-fsd.py
(a symptom seen a few times in this list with no obvious solutions).
None of the programs output any error messages, just that they are
using SSE, and fpll.py reports setting initial_freq to 3065000.  I've
sanity checked the logged data in matlab and verified a signal exists
from -3 MHz to +3 MHz.

Any hints as to what I am missing or next steps to debug the issue?

Jared Casper

reply via email to

[Prev in Thread] Current Thread [Next in Thread]