[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Discuss-gnuradio] USRP2 Diagnostics in GRC

From: Umair Naeem
Subject: [Discuss-gnuradio] USRP2 Diagnostics in GRC
Date: Wed, 31 Mar 2010 14:19:55 +0000


I have a problem concerning USRP2. I am using GRC to make flow graphs but I can 
not find USRP2 when I use USRP source block. When I run a simple program with 
only two blocks (USRP source and Scope Sink) I get  following error:

>>> Verbose:
usrp: failed to find usrp[0]
Traceback (most recent call last):
  File "/usr/share/grc/src/ExecFlowGraphGUI.py", line 231, in OnInit
    self.SetTopWindow(FlowGraphFrame(self.flow_graph_file_path))#first argument 
is the flow graph
  File "/usr/share/grc/src/ExecFlowGraphGUI.py", line 159, in __init__
    FlowGraphBuilder.__init__(self, file_path)
  File "/usr/share/grc/src/ExecFlowGraph.py", line 50, in __init__
  File "/usr/share/grc/src/ExecFlowGraph.py", line 145, in _parse_nested_data
    signal_blocks_dict[signal_block.get_id()] = 
  File "/usr/share/grc/src/SignalBlockDefs/USRP.py", line 182, in make
    u = type.parse()[0](number, nchan=1)
  File "/usr/lib/python2.6/site-packages/gnuradio/usrp/usrp_swig.py", line 
1699, in source_c
    return _usrp_swig.source_c(*args, **kwargs)
RuntimeError: can't open usrp

I also tried using USRP Diagnostics in Help menu but it also does nt detect.
I run find_usrps through terminal and it works like,
00:50:c2:85:34:6f hw_rev = 0x0400

Umair Naeem
MSc Communication Engineering
Chalmers University ot Technology, Sweden.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]