[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Discuss-gnuradio] BPSK GNU radio companion/USRP help!

From: alexandra noriega
Subject: [Discuss-gnuradio] BPSK GNU radio companion/USRP help!
Date: Mon, 26 Apr 2010 09:46:38 -0700 (PDT)

Dear GNU Society,

My team mate and I are trying to transmit a vector length of 1010110 which constantly repeats. We are trying to send the signal using BPSK modulation/demodulation. For this we are using grc.

TX block parameters:
repeated bit vector source --> chunks to symbol --> rrc (interpolation: 400, gain: 10k, sample rate: 500kHz, symbol rate: 1, alpha, 1, #of taps: 22) --> usrp sink (interpolation: 512, frequency: 2.45GHz, gain: 0); this is transmitted through the rf antenna connected to the USRP1 with the daughter board rfx2400 with a frequency range of 2.4GHz-2.5GHz.

RX block parameters:
usrp source(decimation: 128, frequency: 2.44998GHz due to offset, gain: 30) -->agc (rate: 500kHz, ref.:1, gain:0, max gain:1) --> rrc (decimation: 400, gain 1, sample rate: 500kHz, symbol rate: 1, alpha: 350m, taps: 22) --> costas loop (alpha: 20m, beta: 400u, max freq: 2.5G, min freq: 2.4G)--> M&M clock recovery (omega:2, gain omega:100, mu: 500m, omega rel. limit: 100u) --> binary slicer.

Our symbol rate is: 250K, data rate: 500kHz, ADC rate: 64M, sps: 2. Our program does not seem to be working. Please need any type of thought if possible!

Also, we've tried running the RX and TX benchmark examples in the following path in the GNU Radio source folder:


And ran the RX program only, using the command:

./benchmark_rx.py - f 2.45G

Once the RX program was running we received packets even without running the TX program (benchmark_tx.py).
Which, I thought even if you don't transmit any information you are not actully sending any information you will still receive everything else in your surroundings(noise, interference, other signals, etc.) Meaning it should not be idle when not transmitting from one usrp to the second usrp.
Could someone correct me please whether my thoughts are correct or incorrect?????????????

Any incite on the cause of the problem will be appreciated.

RFX2400 daughterboards
HG2458RD-SM tri-band antenna (2.4 GHz to 5.8 GHz)

Any feedback is very much appreciated.

Thank you to anyone who chooses to participate in this times of confusion.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]