[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Discuss-gnuradio] find_usrps not working

From: Hariharan Shankar Rahul
Subject: [Discuss-gnuradio] find_usrps not working
Date: Wed, 30 Jun 2010 21:16:17 -0400
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20100423 Thunderbird/3.0.4


I am trying to get USRP2 with RFX2400 daughterboard working on Ubuntu 9.10 (karmic). I have followed the instructions here (http://gnuradio.org/redmine/wiki/1/UbuntuInstall).

I installed the firmware and FPGA code on the SD card from http://code.ettus.com/redmine/ettus/projects/public/wiki/U2binaries. I specifically used the "Raw Ethernet" FPGA image (rel-20100603) and the "Raw Ethernet, No WBX or XCVR" Firmware image (Jun 08, 2010).

When I power up the USRP2, all the lights first glow, followed by only D and F staying lit. The green light on the ethernet is also lit. However, find_usrps returns with "No USRP2 found".

I ran it with wireshark. The command does send a broadcast ping packet from the machine but receives no response. The orange light briefly flashes at the time the packet is sent, both on the PC and on the USRP.

I tried the command with both the ethernet cards on the machine after running ethtool to ensure that the problem might not be due to some autonegotiation settings etc. On one of the cards, it says the command is not supported, but on the other, it says "rx unmodified, ignoring" and "no pause parameters changed, aborting".

I have tried the command with two different USRPs to try and eliminate the possibility that it might be a USRP issue too.

At this point, I am not sure what to do. Maybe the problem is a firmware/FPGA mismatch with the installed gnuradio software, but I am not sure, and I don't know what versions to use if that is indeed the problem.

(The sketch of my problem seems similar to the one outlined by another person here:
except that I am _not_ using the WBX daughterboard. I also tried all the above with and without my RFX2400 daughterboard connected in case the problem was with the RFX2400).

Any suggestions about how to fix the problem?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]