[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Discuss-gnuradio] gnuradio on osx 10.6.4

From: Ninja
Subject: [Discuss-gnuradio] gnuradio on osx 10.6.4
Date: Sun, 18 Jul 2010 16:35:45 +0700

Hello all,

apology if these question ever been discussed before, but i am trying google 
with no luck. 

I am following installing gnuradio on osx from 
https://radioware.nd.edu/documentation/install-guides/mac-os-x until find 
problem at the time configuring gnuradio.

It seems can't find Python.h, here's the output:

checking for python... /usr/local/bin/python
checking for python version... 2.6
checking for python platform... darwin
checking for python script directory... ${prefix}/lib/python2.6/site-packages
checking for python extension module directory... 
checking for Python include path... /usr/local/include/python2.6
checking Python.h usability... no
checking Python.h presence... no
checking for Python.h... no
configure: error: cannot find usable Python headers
bash-3.2$ ls /usr/local/include/python2.6/
Python-ast.h            compile.h               iterobject.h            
py_curses.h             rangeobject.h
Python.h                complexobject.h         listobject.h            
pyarena.h               setobject.h
abstract.h              datetime.h              longintrepr.h           
pyconfig.h              sliceobject.h
asdl.h                  descrobject.h           longobject.h            
pydebug.h               stringobject.h
ast.h                   dictobject.h            marshal.h               
pyerrors.h              structmember.h
bitset.h                enumobject.h            metagrammar.h           
pyexpat.h               structseq.h
boolobject.h            errcode.h               methodobject.h          pyfpe.h 
bufferobject.h          eval.h                  modsupport.h            
pygetopt.h              sysmodule.h
bytearrayobject.h       fileobject.h            moduleobject.h          
pymacconfig.h           timefuncs.h
bytes_methods.h         floatobject.h           node.h                  
pymactoolbox.h          token.h
bytesobject.h           frameobject.h           object.h                
pymath.h                traceback.h
cStringIO.h             funcobject.h            objimpl.h               pymem.h 
cellobject.h            genobject.h             opcode.h                
pyport.h                ucnhash.h
ceval.h                 graminit.h              osdefs.h                
pystate.h               unicodeobject.h
classobject.h           grammar.h               parsetok.h              
pystrcmp.h              warnings.h
cobject.h               import.h                patchlevel.h            
pystrtod.h              weakrefobject.h
code.h                  intobject.h             pgen.h                  
codecs.h                intrcheck.h             pgenheaders.h           

what is the meaning of "configure: error: cannot find usable Python 
headers"?the Python.h is there, and I already tried using original python from 
apple, python from MacPython, and compile manually but same result occurred. 
Above sample was taken from python compiled manually. 

please advise.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]