[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] gnuradio on osx 10.6.4

From: Elvis Dowson
Subject: Re: [Discuss-gnuradio] gnuradio on osx 10.6.4
Date: Mon, 19 Jul 2010 09:55:35 +0400

Hi Michael,
                       I was wondering if you could help me fix an issue with libusb not being recognized on Mac OS X 10.6.4.

I downloaded libusb-1.0.8 from the following location:

$ cd libusb-1.0.8
$ ./configure 
$ make -j 4 
$ sudo make install

Installation went fine and the headers are stored in /usr/local/include/libusb-1.0/libusb.h

However, when I run gnuradio configure, I get the following error:

checking for USB... no
checking for USB... no
checking usb.h usability... no
checking usb.h presence... no
checking for usb.h... no
USRP requires libusb header 'usb.h' which was not found or was not usable. See http://www.libusb.org
Unable to find dependency libusb.

I checked config/usrps_libusb.m4, but I don't know why it is not detecting the library, and jumping straight to the end and trying to look for usb.h

# $1 is $req_libusb1:
#   yes : check libusb-1.0
#   no  : check libusb-0.12
#   ""  : check libusb-0.12

  dnl Use PKGCONFIG to check for packages first, then check to
  dnl make sure the USB_* variables work (whether from PKGCONFIG
  dnl or overridden by the user)

  if test x$1 = xyes; then
    PKG_CHECK_MODULES(USB, libusb-1.0, [


    if test $libusbok = no; then
      dnl if not, see if the pkgconfig module 'libusb-legacy' is available
      PKG_CHECK_MODULES(USB, [libusb-legacy], [
        ], [libusbok=no])
    dnl set variables for further testing

Best regards,


reply via email to

[Prev in Thread] Current Thread [Next in Thread]