[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] GNU Radio via MacPorts Updated

From: Michael Dickens
Subject: Re: [Discuss-gnuradio] GNU Radio via MacPorts Updated
Date: Tue, 14 Sep 2010 17:12:01 -0400

Hi Dave - We're just discussing this issue (32-bit execution) on the MacPorts' 
lists.  The quick end-result is: With the current MacPorts' provided python2.6 
or older, the PREFER_32_BIT stuff does not work because 'python' is actually 
just a wrapper around 'exec' and the bit-preferences are no passed through.  
Apple's python2.6 -does- work, as does python2.7 and newer, because this 
command was moved to "posix_spawn"; see < 
http://www.opensource.apple.com/source/python/python-44.1/2.6/ > for the source 
code and changes Apple made (somewhere in there).

As to your actual error when running "usrp_fft.py": Apparently WX is not 
installed as 64-bit.  I haven't gotten this far in my testing (lots on my queue 
already), but my memory is that this has been an issue for a -long- time & 
still isn't resolved.  I don't remember the exact root cause any longer.

Sorry I can't be of more help yet; thanks for testing & reporting back. - MLD

On Sep 14, 2010, at 4:49 PM, dave k wrote:
> guys im having this issue with wxgui when trying to run usrp_fft.py on snow 
> leopard
> $ usrp_fft.py 
> Traceback (most recent call last):
>  File "/opt/local/bin/usrp_fft.py", line 27, in <module>
>    from gnuradio.wxgui import stdgui2, fftsink2, waterfallsink2, scopesink2, 
> form, slider
>  File "/opt/local/lib/python2.6/site-packages/gnuradio/wxgui/stdgui2.py", 
> line 24, in <module>
>    import wx
>  File 
> "/var/tmp/wxWidgets/wxWidgets-13~231/2.6/DSTROOT/System/Library/Frameworks/Python.framework/Versions/2.6/Extras/lib/python/wx-2.8-mac-unicode/wx/__init__.py",
>  line 45, in <module>
>  File 
> "/var/tmp/wxWidgets/wxWidgets-13~231/2.6/DSTROOT/System/Library/Frameworks/Python.framework/Versions/2.6/Extras/lib/python/wx-2.8-mac-unicode/wx/_core.py",
>  line 4, in <module>
> ImportError: 
> /System/Library/Frameworks/Python.framework/Versions/2.6/Extras/lib/python/wx-2.8-mac-unicode/wx/_core_.so:
>  no appropriate 64-bit architecture (see "man python" for running in 32-bit 
> mode)
> i have tried 
> defaults write com.apple.versioner.python Prefer-32-Bit -bool yes
> and 
> but still get the same error
> any ideas?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]