[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] GNU Radio via MacPorts Updated

From: Elvis Dowson
Subject: Re: [Discuss-gnuradio] GNU Radio via MacPorts Updated
Date: Wed, 15 Sep 2010 10:32:03 +0400


On Sep 15, 2010, at 12:49 AM, dave k wrote:

guys im having this issue with wxgui when trying to run usrp_fft.py on snow leopard

$ usrp_fft.py
Traceback (most recent call last):
 File "/opt/local/bin/usrp_fft.py", line 27, in <module>
   from gnuradio.wxgui import stdgui2, fftsink2, waterfallsink2, scopesink2, form, slider
 File "/opt/local/lib/python2.6/site-packages/gnuradio/wxgui/stdgui2.py", line 24, in <module>
   import wx
 File "/var/tmp/wxWidgets/wxWidgets-13~231/2.6/DSTROOT/System/Library/Frameworks/Python.framework/Versions/2.6/Extras/lib/python/wx-2.8-mac-unicode/wx/__init__.py", line 45, in <module>
 File "/var/tmp/wxWidgets/wxWidgets-13~231/2.6/DSTROOT/System/Library/Frameworks/Python.framework/Versions/2.6/Extras/lib/python/wx-2.8-mac-unicode/wx/_core.py", line 4, in <module>
ImportError: /System/Library/Frameworks/Python.framework/Versions/2.6/Extras/lib/python/wx-2.8-mac-unicode/wx/_core_.so: no appropriate 64-bit architecture (see "man python" for running in 32-bit mode)

i have tried
defaults write com.apple.versioner.python Prefer-32-Bit -bool yes
but still get the same error
any ideas?

Just check if wxWidgets/wxPython is working correctly by typing the following commands:

$ python
>>> import wx
>>> exit()

Best regards,

Elvis Dowson

reply via email to

[Prev in Thread] Current Thread [Next in Thread]