[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Discuss-gnuradio] UHD IP Address Setting Issue

From: Gregory, Adam
Subject: [Discuss-gnuradio] UHD IP Address Setting Issue
Date: Tue, 16 Nov 2010 16:57:45 -0000

Hi all,


I’m trying to get a MIMO setup working using USRP2s with the UHD drivers. I have a PC with 2 gigabit Ethernet interfaces, and a USRP2 connected to each.


My problem is that I can’t change the USRP2 IP address so that the two devices have different addresses. I can set the IP address in the motherboard EEPROM using usrp_burn_mb_eeprom, and I can see the updated IP address reported when I run uhd_usrp_probe, but the IP address the USRP2 answers to is still


Power-cycling the device has no effect, nor does trying another PC in case of any address caching. I’ve tried with UHD firmware & fpga images built myself from the latest git, and also with the 01/09/2010 release.


I’ve seen on the mailing list archives that some people have had success with MIMO and UHD, and I haven’t found any reference to IP address problems. I must be missing something. Could anyone help please?


Thanks in advance,



Roke Manor Research Ltd, Romsey,
Hampshire, SO51 0ZN, United Kingdom

Part of the Chemring Group

Registered in England & Wales at:
Chemring Group PLC, Chemring House, 1500 Parkway,
Whiteley, Fareham, Hampshire PO15 7AF, ENGLAND.
Registered No: 267550


Visit our website at www.roke.co.uk


The information contained in this e-mail and any attachments is
proprietary to Roke Manor Research Ltd and must not be passed to any
third party without permission. This communication is for information
only and shall not create or change any contractual relationship.


Please consider the environment before printing this email

reply via email to

[Prev in Thread] Current Thread [Next in Thread]